Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

FPV - OSD - camera dsiplay started to funk out

Discussion in 'Phantom 2 Discussion' started by Archie Andrews, Jun 26, 2014.

  1. Archie Andrews

    May 21, 2014
    Likes Received:
    Has anyone's FPV and video ever started to go weird during flight? My display and recording started to turn all Gamma like.

    I was out yesterday filming in countryside, lot of trees and moorland. All of a sudden the video display on my FPV and the subsequent recorded video started to go all gamma like (see screen shot)

    After that the next flight all I had was the OSD info and no display.

    After checking everything through, repowering and unplugging the cables, resetting channels on the FPV everything eventually returned to normal.

    I could say it was probably the SD card (Samsun 16GB, 10), but I also lost the FPV camera data but still had the OSD info on screen. Then that itself disappeared and had to try unplugging everything and repowering sorted it. No pattern or clue there really.

    I also sometimes get a large exclamation icon saying "REPAIRING VIDEO" - that makes me suspicious of the SD card so I have done a full format and will monitor how it goes.

    Frustrating when you go out for the day with only 3 batteries worth of flying time and trying to get decent footage.

    Anyone else experienced this?


    P2 - H3 3D Gimbal with GoPro Hero 3 black

    Attached Files: