Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Fpv HELP!

Discussion in 'Phantom 1 Help' started by Phantom12014, Dec 26, 2014.

  1. Phantom12014

    Joined:
    Sep 15, 2014
    Messages:
    76
    Likes Received:
    17
    So it's been a couple days sense I fly my phantom the last time I did I was flying and all of a sudden I had few drops rain but I mean really just a few nothing crazy...ok so today I treid installing a new 2000mW transmitter and nothing no video or wouldn't power up cam but it had power so I thought maybe I had just bad transmitter so I put my 250mw fatshark one back on and now it same exact thing so I took gopro off totally and tried using the battery in it nothing no power and computer won't even recognize it....I'm so confused could've the new transmitter blew it all up...im so pissed and confused...can anyone one help plz
     
  2. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando

    Holy pronouns batman!

    Which is not getting power? The go-pro or the Phantom?
     
  3. burlbark

    Joined:
    Oct 6, 2014
    Messages:
    502
    Likes Received:
    16
    There is a batch of bad FPV usb cables out there killing every gopro out there. Mine is also dead and the seller refunded my money for the cable, big deal. The pin outs are all wrong on the mass cable production and it swaps the lead every way but right. I posted a diagram on my facebook page. Its a little farther down in my timeline and you cant miss it.

    https://www.facebook.com/USdronerepair