Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Fpv help needed, no image

Discussion in 'FPV (First Person View)' started by forenplayer, Nov 29, 2015.

  1. forenplayer

    Joined:
    Feb 6, 2015
    Messages:
    13
    Likes Received:
    1
    Location:
    Toronto, Canada
    I have phantom2 v2 and i installed iosd mini and immersion 600mv tx. I've done it many times before... I have gopro3 white. I do get iosd info on my fatshark attitude googles, but no image from gopro. Gopro is set to NTFS, av switch on goggles is on. The gopro connects to zenmuse gimbal by usb plug on the side with the ribbon. I know the goggles are working i checked them on another phantom. What else can it be? Iosd has latest update
     
  2. kenjancef

    Joined:
    Jul 20, 2015
    Messages:
    1,202
    Likes Received:
    236
    Location:
    East Providence, RI
    Does your GoPro have the latest firmware installed? If so, then you probably got bit with the "No FPV" issue that the Hero 3 Silver's do. For some reason the latest firmware for the Silver turns off FPV capabilities.
     
  3. Kneepuck

    Joined:
    Nov 23, 2015
    Messages:
    88
    Likes Received:
    21
    You might verify the resolutions are compatable as well. For example, the Dominator V3's will not accept anything more than 720p resolution. Anything else, no image.
     
  4. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,099
    Likes Received:
    404
    Location:
    Commerce Twp,MI
    The most likely it's either the ribbon is damaged or isn't completely seated in the USB adapter. There is one other possibility is a damaged ribbon that goes into the bottom of the horizontal motor assembly on the gimbal.

    There is also the possibility if you updated the GO white's firmware But we have only heard of a problem with the updates to 3+ silver and Black cameras but then anything is possible.