Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

FPV failure - updated info, help needed.

Discussion in 'FPV (First Person View)' started by pilsburypie, Nov 26, 2014.

  1. pilsburypie

    Joined:
    Jul 18, 2014
    Messages:
    160
    Likes Received:
    2
    Location:
    Birmingham, UK
    My FPV suddenly stopped working a couple of months back. No reason what so ever, no crashes, bangs etc - worked fine one day, "No signal" displayed on screen the next. Tried a few trouble shooting tips but still "no signal". Due to the Phantom 2 and FPV setup being 3 months old I spoke to the dealer. He asked me to send the monitor(RX) and VTX in for test.

    Took an age to get back, and the chap has sent me a new VTX. He also text me a picture of the monitor working on his test bench with another transmitter.

    BUT, still not working. Here are some facts and some assumptions. I'd like your thoughts as although the dealer has provided a new VTX, he is rather illusive and is no customer service expert!!!

    FACTS:
    1. Go pro 3 records fine
    2. Ribbon cable from Zenmuse gimbal changed (just in case) camera charges when Phantom on
    3. Monitor works and receives on dealers test rig
    4. Transmitter gets power from Phantom (red led lights up)
    5. the yellow video cable from the gimbal to the board is fine (tested)

    Thoughts/assumptions
    1. Can 2 transmitters be bad?
    2. Could the video out from the gopro be at fault?
    3. could the Phantom wiring or workings be at fault?

    When the issue first occurred, I did open up the Phantom and look at the wiring.... just a quick look if I could see anything obvious but not sure what I was looking for other than a clearly snapped wire! How can I properly check the wiring for the video transmitter?

    What are the chances of the gopro being at fault? How can I check it provides video out?
     
  2. pilsburypie

    Joined:
    Jul 18, 2014
    Messages:
    160
    Likes Received:
    2
    Location:
    Birmingham, UK
    MORE INFO:

    Google has led me to test 2 new things:

    1. could be gopro fault - not putting video out. I have just ordered a gopro composite cable to hook up to my tv so I can tell if I'm getting video out. Comes tomorrow. Gonna be bad and return to store after ;)
    2. Could be the Phantom video board is faulty - these are £45. Not really too happy to take a punt on this - doubt I can return if it makes no difference
    3. Looking at the zenmuse 3d gimbal, the ribbon cable I changed was the very last short bit that links the gimbal to the gopro - there is extensive ribbon cabling all over the gimbal - could that be duff? That would be a job and a half to change

    Any other ideas how to troubleshoot? I am hitting desperation now. Phantom flying for me is all about the video side and I simply can't frame my shots without.