Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Foolproof startup procedure for P3P

Discussion in 'Pro/Adv Discussion' started by movius, Jan 17, 2016.

  1. movius

    Joined:
    Jan 11, 2016
    Messages:
    153
    Likes Received:
    45
    I've enjoyed some great posts so I'd like to share a problem and solution I've had with my new P3P startup process. It may be old news to many, but it took me ages to figure it what was going on. It might help others.

    The problem: Basically, starting up the P3P was completely hit or miss. I tried all sorts of ways. The basics are that you start up the controller, then the aircraft, wait for the two to pair, then start up the DJI Go app (or Litchi or other). Simple really!! Except, every time I tried to connect the controller to the P3P with the USB cable already connected to the pbone I never got a green light (it didn't matter if the app was loaded or not). Startup without the cables connected was equally troublesome. On many occasions even when I did have a green light, when I connected the phone (it's a Samsung Note 3) using the USB cable to the controller, the signal between the controller and P3P dropped immediately. Grrrr... No rhyme or reason as far as I could see.

    The solution: Get your mobile / tablet / phablet ready with the micro USB connected but leave the large USB unconnected from the controller. Start the controller, start the P3P and wait for the two to connect (green light on). Now, plug in the big USB to the controller. For me this auto loads the Litchi app (confirm to use the USB port if prompted). If not, simply load the app you prefer, green light should stay on and all is well.

    This works everytime. For old hands it probably isn't news but it took me quite a while to figure out what the problem was and how to fix it.

    I suspect there's an issue with the micro USB on my phone (and maybe others) spiking the controller or aircraft when plugging in, breaking the connection. If you have this problem, this process might just help you too.

    Kind regards
    David

    Sent from my SM-N9005 using Tapatalk
     
  2. Rumbaar

    Joined:
    Dec 27, 2015
    Messages:
    261
    Likes Received:
    43
    Location:
    Melbourne, Australia
    For me, I turn on Drone, then turn on controller. It's connected to my display device and it automatically turns on the device (if off) and starts the GO app. I hit show camera and it's connected.
     
  3. generaltso

    Joined:
    Jan 11, 2016
    Messages:
    114
    Likes Received:
    18
    Location:
    Vermont
    Works fine for me regardless of the order I turn things on, plug in USB, or launch the app. I've been using an iPad Mini 4 and iPhone 6.
     
  4. m0j0

    Joined:
    Dec 26, 2015
    Messages:
    1,533
    Likes Received:
    530
    I would not start the drone first. I think it's good practice to start the TX first. I'm sure it isn't a big deal but that's the way I have been taught.
     
  5. WiscHusker

    Joined:
    Dec 19, 2015
    Messages:
    7
    Likes Received:
    0
    The following has never failed me.

    Connect iPad to remote via USB
    Turn on remote
    Start DJI GO App
    Start P3A
     
  6. BVC

    BVC

    Joined:
    Feb 21, 2015
    Messages:
    533
    Likes Received:
    182
    Location:
    Sacramento, CA / Dener, CO
    I turn on and plug in the tablet to the remote. Turn on the remote. Turn on the drone. After the camera dances I start up the DJI GO app. Then enter camera mode and start my pre-flight.

    ..this thread is NULL.
     
    Bill7259 likes this.
  7. With The Birds

    Joined:
    Jan 4, 2016
    Messages:
    2,608
    Likes Received:
    742
    Location:
    Australia
    Radio first somethines with ipad conectred before aircraft powered on sometimes after. Never noticed a connection issue. Waiting for aircraft to warm up was the biggest issue untill i did the 20mins in the fridge before imu calibration trick.
     
  8. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,142
    Likes Received:
    1,658
    Location:
    San Francisco, CA
    Never start drone first.
    RC >>>Tablet>>Drone during startup
    Drone>>Tablet>>RC during shut off

    Idea is that controls should be enabled first and switched off last.
     
    m0j0 likes this.
  9. Rumbaar

    Joined:
    Dec 27, 2015
    Messages:
    261
    Likes Received:
    43
    Location:
    Melbourne, Australia
    Only times I've ever had the RC not find the drone (red light) was when I've turned the RC on before the drone.

    How important is order, is the drone going to go rogue without an RC and auto fly away?
     
  10. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,142
    Likes Received:
    1,658
    Location:
    San Francisco, CA
    Usually nothing happens but that's the recommended procedure to avoid any mishap.

    Logic is simple, no car should be started without engaging brakes.

    Drone should always be in control.
     
  11. Rumbaar

    Joined:
    Dec 27, 2015
    Messages:
    261
    Likes Received:
    43
    Location:
    Melbourne, Australia
    So the RC is the engine brake in this scenario?
     
  12. summertt

    Joined:
    Jan 18, 2016
    Messages:
    1
    Likes Received:
    0
  13. With The Birds

    Joined:
    Jan 4, 2016
    Messages:
    2,608
    Likes Received:
    742
    Location:
    Australia
    Dunno if id say the RC is the brake.... most digital RC stuff you dont have problems. The older FM gear powering your aircraft fist you could get the motors powering up. And turning of radios first can be bad also. I had a heli with main rotors off, had been checking the servo directions after putting a new rx in. Turned the transmitter off without thinking and almost ended up witj a severed tendon in my thumb. Tail rotors were still on. Always radio on first and off last.
     
    Bill7259 likes this.
  14. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,142
    Likes Received:
    1,658
    Location:
    San Francisco, CA
    In reality its not but it controls all motions of aircraft. That was an example to say that controller should be active all the time before aircraft is switched on.
     
  15. gkol

    Joined:
    Aug 2, 2015
    Messages:
    38
    Likes Received:
    16
    Any RC hobbyst will tell you to turn the RC first! It has it's root before 2,4GHz standard when RC's were working on low frequencies and it was highly probable that someone is flying at your frequency.
     
    LWC1496 likes this.
  16. Rumbaar

    Joined:
    Dec 27, 2015
    Messages:
    261
    Likes Received:
    43
    Location:
    Melbourne, Australia
    Ah, as the drone and RC are linked and cannot be controlled by someone else. This isn't an issue related to these devices?
     
  17. movius

    Joined:
    Jan 11, 2016
    Messages:
    153
    Likes Received:
    45
    As I mentioned, I think the micro USB on the Note 3 is the culprit here. Most people seem to have a trouble free startup whereas unless I follow the procedure I outlined above to the letter, I always lose the connection. Very strange!!

    Sent from my SM-N9005 using Tapatalk
     
    jiggyb21 likes this.
  18. Phantomfreak

    Joined:
    Dec 12, 2015
    Messages:
    196
    Likes Received:
    70
    Using an iPhone 6 Plus and GO app. Attach phone to RC with cable. Turn on GO app. Turn on RC, app notifies me RC connected, prompts me to turn on the Phantom. When this is done I am connected and camera button becomes active. I have had over 50 flights and 500,000 ft. with this exact same procedure everytime, no issues.
     
    movius likes this.
  19. m0j0

    Joined:
    Dec 26, 2015
    Messages:
    1,533
    Likes Received:
    530
    Not likely, but the theory is you should enable controls before you enable the quad.
     
  20. Michel Rivet

    Joined:
    Nov 30, 2015
    Messages:
    89
    Likes Received:
    5
    I have not much experience but what i do is i turn on the transmitter, the drone and when i connect the pad it automaticaly open dji go
    i don't have to click on dji go it opens by itself