Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Flyaway questions

Discussion in 'General Discussion' started by efbld2f, Apr 30, 2014.

  1. efbld2f

    Joined:
    Apr 19, 2014
    Messages:
    4
    Likes Received:
    0
    Hello. So, I sent my Phantom 1 up to about 400ft last night and then it refused to respond to commands. It slowly drifted for another 10+ minutes as I ran under it before it smashed into the ground in a field (fortunately). I always ALWAYS set, wait, and then verify the return-to-home feature before any flight. Further, the batteries were all fully charged. (obviously, engaging the failsafe, antenna orientation, and ultimately turning off the TX had no effect)

    Interestingly, when it did finally begin to land, it didn't seem to engage the 2nd warning that forces a fast landing. It just seemed to lose altitude as it lost power. Further, the flight before this, I lost control, but I was able to conduct a controlled landing. It seemed like none of the directional controls were responding accurately and I had no forward control. It just kind of hovered with no lateral movement.

    I bought it about two weeks ago and haven't crashed it until this incident. What happened? How do I fix it?
     
  2. Ozzyguy

    Joined:
    Dec 6, 2013
    Messages:
    811
    Likes Received:
    1
    Location:
    Townsville,Australia.
    Have you changed your transmitter batteries at all during that two weeks. I use rechargeable batteries and charge them before every session.
     
  3. enseth

    Joined:
    Apr 2, 2014
    Messages:
    67
    Likes Received:
    0
    And you took it up again and to 400'! That's asking for trouble.