Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Flew my P3P next to a P2V+, terrible signal

Discussion in 'Pro/Adv Discussion' started by LordEvil, Jul 12, 2015.

  1. LordEvil

    Joined:
    Dec 24, 2014
    Messages:
    243
    Likes Received:
    61
    Location:
    San Antonio Texas
    It's pretty bad flying your P3P next top a P2V+. As soon as the P2 was cranked up, my signal was lost. Started the P3 again and the video would freeze, come and go out completely. Flew fine but no video feed.

    Switched to auto channel, little bit better video those still froze and looked awful, but the camera would tilt sideways almost.

    I searched and didn't see any other topic, anyone else have this issue, is there a fix? The channels, all channels would spike red.
     
  2. UKFlyer

    Joined:
    Jul 20, 2014
    Messages:
    505
    Likes Received:
    64
    Location:
    Midlands, UK
    I flew my P3P with a PV2+, the video feed was sometimes choppy but no other issues, channel was left on auto.
     
  3. BenDronePilot

    Joined:
    Dec 7, 2013
    Messages:
    1,204
    Likes Received:
    131
    The p2v+ wifi range extender is getting in the way of your p3s signal. It would have worked better prior to the p3 loosing 75% of its available channels. Best bet is make sure you're not pointing your p2 range extender directly at your p3. Also using the windsurfer style foil antenna to make your p3 signal directional will also help a lot with the signal to your p3. Additionally I was going to suggest manual channel selection to the least worst one.