Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Flashing Red Tail Lights

Discussion in 'Phantom 2 Discussion' started by wkf94025, Jun 7, 2014.

  1. wkf94025

    Joined:
    Jan 19, 2014
    Messages:
    608
    Likes Received:
    8
    Location:
    St. Helena, CA
    Two observations about the red tail light behavior on my P2 that don't match what's in the Assistant help text or the manual. I am running v3.04 firmware and using the default 30%/15% battery warning levels. Puzzling behavior includes:
    1) I am getting the flashing red tail lights well before 30%. On two flights this morning, with "normal" flying, the tail lights went red around 45%. I burned another battery doing a simple GPS hover test for the entire battery (really boring) and the tail lights went red just below 30%. So shy bug, apparently, or something about LiPo depletion that I don't understand.
    2) The help text in the Assistant describes different visual cues at 30% and 15%: "will blink red slowly and continuously" at low battery level (30%), and "will blink quickly and continuously" at critical battery level (15%). I am not seeing a visual difference between the two.

    All I am seeing is one state of flashing red tail lights, from ~45% battery level all the way down to shutdown in the low single digit %'s.

    Components on board: H3-3D, Hero3+, iOSD Mini, IRC600 VTx, FPV hub

    What are others seeing?

    A related behavior that I'm not crazy about: no matter my altitude, below 30% it takes nearly full left stick forward to maintain altitude. Anything less than say 95% full left stick forward and the P2 sinks. If no input on left stick, it will sink at about 0.4 m/sec. Is that a "feature"? Not for me it's not.


    Kelly
     
  2. shartlza

    Joined:
    Oct 21, 2013
    Messages:
    304
    Likes Received:
    5
    Location:
    Orange County, CA
    I am kind of encountering the same thing, but my flight time has dropped a few minutes and I am auto descending at 27% and not at the 15% second level I have it set to. Now I am starting to think this could be a 3.04 firmware bug. Maybe the firmware is coded to be more sensitive to battery voltage. I may start another thread about this.
     
  3. WessexWyvern

    Joined:
    Apr 26, 2014
    Messages:
    166
    Likes Received:
    1
    I don't get stage 1 warning lights at all but instead get stage 2 warning lights come on at 30% battery power. Everything else seems normal and it auto descends at 15%. This happened the first flight after upgrading to 3.04.
     
  4. WessexWyvern

    Joined:
    Apr 26, 2014
    Messages:
    166
    Likes Received:
    1
    Double post
     
  5. AnselA

    Joined:
    Jan 2, 2014
    Messages:
    896
    Likes Received:
    1
    Location:
    Declination +8° 11'
    What's the total weight of your quad?
     
  6. Redman

    Joined:
    Jun 8, 2014
    Messages:
    3
    Likes Received:
    0
    I get about 5 min of flying time before I get the red light fast flash and it starts to auto land. Battery meter reads the Battery to be full aroun 12.5 and the asst. software says its full at 12.5. Nothing on it but H3 3D gimbal. Any Ideas?
     
  7. BigBadFun

    Joined:
    Mar 17, 2014
    Messages:
    154
    Likes Received:
    1
    Location:
    Christchurch, New Zealand
    Yes - I get flashing reds at 35% and it tries to autoland on 3.04 :?:
     
  8. shartlza

    Joined:
    Oct 21, 2013
    Messages:
    304
    Likes Received:
    5
    Location:
    Orange County, CA
  9. gecarey

    Joined:
    Feb 21, 2014
    Messages:
    136
    Likes Received:
    15
    Location:
    San Mateo CA USA
  10. shartlza

    Joined:
    Oct 21, 2013
    Messages:
    304
    Likes Received:
    5
    Location:
    Orange County, CA
    That is very interesting that your battery started doing this after 70 discharges because that is exactly when mine started acting up. Did you also notice thag your flight time was reduced? I would normally get 17 min flight time to about 25% with just a gimbal, then all of a sudden my flight time dropped to 14 to 15 minutes. Could you please reply in the post I listed above, so we can keep a log.