Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

First Vision+ Flight - Gimbal Acting Up?

Discussion in 'Phantom 2 Vision + Discussion' started by MattUNI2001, May 13, 2014.

  1. MattUNI2001

    Joined:
    May 7, 2014
    Messages:
    82
    Likes Received:
    0
    Location:
    Phoenix, AZ
    To my delight, my Vision+ arrived a day earlier than expected! I'm quite experienced in RC, but this is the first Phantom I've flown. After getting the batteries charged, going through all of the instructions, switching to Naza mode, and downgrading my firmware to 1.08, I fired up the Vision+. The first thing I noticed was that every time I turn it on, the gimbal straightens the camera and levels it perfectly for about 4 seconds. Then, it violently jerks the camera and sticks in in a downward angle, which is where it stays until I get the app connected and manually change it back to level. Once I change it via the phone app, it seems to work exactly as expected. Does anybody else's camera violently tilt all the way down when you turn on your Vision+?

    It is pretty windy here today, so I only flew it for about 5 minutes, but it flew beautifully (I had to calibrate the compass twice because the first time failed for some reason). I am so excited about the quality of the video that was taken as well as how easy of a machine this is to control. It has exceeded my expectations, and I hope it doesn't decide to fly away on me. I also hope the gimbal/camera does not give me any of the issues others have been seeing.
     
  2. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    That's normal - well it goes to about 45 degrees until you connect by the app and adjust it.
    I'm not sure why you wanted to change to the outdated firmware though.

    It's actually a bit concerning that a few bad reports with a suspicion that the firmware was somehow involved are are taken so seriously.
    I would think the actual changing from one to another either way is more a risk factor than anything; for a start you really ought to consider doing a full calibration now.
     
  3. MattUNI2001

    Joined:
    May 7, 2014
    Messages:
    82
    Likes Received:
    0
    Location:
    Phoenix, AZ
    Awesome - I'm glad to hear that is normal. The super slow descent is the main reason I have not upgraded to the latest firmware. I'm not really near any no-fly zones, and I don't anticipate I will be, so that isn't a big concern. However, I did also read that 1.08 "seemed" to be more stable than the other firmware. I agree that it does seem odd to downgrade MULTIPLE firmwares back, however.. :)
     
  4. skyhighdiver

    Joined:
    Dec 19, 2013
    Messages:
    1,007
    Likes Received:
    211
    Location:
    South Dakota
    Im with 4wd I have 20+ flights on the 3.0 firmware ( yes I know new is 3.02) but like to let the new stuff be out for a while to make sure no bugs. Anyway I have had nothing but fantastic results with it I use atti,gps and rth and all work wonderful no issues. Remember most happy people don't leave reviews or write on forums. So for every report you read of trouble there are probably 1000 that are issue free

    Just my 2 cents :cool:
     
  5. ShoreBird

    Joined:
    Apr 14, 2014
    Messages:
    91
    Likes Received:
    8
    Another + that does the same camera boot up. And I am using the 3.02 and have about 20 flights in and no problems.
    Just add me to the positive side....
     
  6. MattUNI2001

    Joined:
    May 7, 2014
    Messages:
    82
    Likes Received:
    0
    Location:
    Phoenix, AZ
    Awesome - I appreciate all of the responses confirming the odd camera boot up as well as the newer firmware being used with no issues. I LOVE this thing. 3 flights in so far with some pretty amazing pictures and videos!!!
     
  7. Chamb0 FPV

    Joined:
    May 9, 2014
    Messages:
    18
    Likes Received:
    1
    5 flights with mine so far and lovin it, 3.2 works fine for me, cam goes to 45 degrees on start up so it's normal. My mind does wonder when people on here moan about the video quality and say its poor. I still have videos of my AR Drone which was only 2/3 years ago now that's poor video LOL.