Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

First flight DJI flew away

Discussion in 'Phantom FC40 Discussion' started by comanforterie, Sep 24, 2014.

  1. comanforterie

    Joined:
    Sep 24, 2014
    Messages:
    6
    Likes Received:
    0
    can anyone help me with this... my first flight with the Phantom FC40......i turned on the transmitter first....got bright yellow light....then plugged in the Phantom....it blinked until it did many fast green blinks....then it did slow repeated green blinks....which i think means it's ready to fly, and that it has a good GPS fix .....i activated the motors....then lifted it slowly off the ground to about 10 feet.....it started to coast....and i had no control......it started to drift fast away from me so i cut the engines.......did it have a good GPS or not?....the top right switch (sw1) was in the upper position, (presumably GPS) and the Phantom was blinking a slow green

    do i need to calibrate the comus module before doing anything?......or do i need to use the assistant software first to activate the IOC?

    Phil
     
  2. Mandrake

    Joined:
    Mar 29, 2014
    Messages:
    222
    Likes Received:
    0
    Location:
    Melbourne , Australia
    Definitely tick the IOC box.. Then do the compass dance as its probably set for northern Hemisphere.
     
  3. Fotoman

    Joined:
    Jul 17, 2014
    Messages:
    34
    Likes Received:
    0
    Sounds like you didn't calibrate the compass before taking off. I'm guessing that's why it flew away (conflict between the compass and the GPS).

    Would also be a good idea to upgrade the firmware of the Phantom and the transmitter.
     
  4. Rustysocket

    Joined:
    Aug 22, 2014
    Messages:
    98
    Likes Received:
    0
    Setup IOC and Failsafes in Naza, then calibrate compass, before flying again
     
  5. darwin-t

    Joined:
    Apr 28, 2014
    Messages:
    513
    Likes Received:
    5
    And set the limits (In NAZA Assistant, under the Advanced tab). They are set to 2,000 yards. Set the altitude one to 50 yards or less, the distance ones to 100 yards or less.

    Check the motor cutoff, make sure it is set to "Intelligent"

    Set the bottom position of S1 to "Failsafe"

    Check to make sure Failsafe is set to come home and land and not just land.

    And yes, turn on IOC

    I wouldn't worry about updating firmware or doing any calibration of the controller. Your firmware should be up to date and I personally think the likelihood of any of that being wrong is slim.

    To do all of this, go here, download the drivers and latest version of NAZA Assistant. Install the drivers, then Assistant. Use the cable that come with your FC40 to hook it to your PC. The port is on the bottom of the FC40, at the back.

    Take your propellers off, turn on your controller and THEN your FC40

    If you don't have it already, download the owners manual and the NAZA-M Quick Start Manual and read them.

    http://www.dji.com/product/phantom-fc40/download

    I'd be interested in knowing what the defaults are on motor cutoff and failsafe.
     
  6. Lonewolf

    Joined:
    Jun 3, 2014
    Messages:
    447
    Likes Received:
    108
    I agree with the mentions from others about calibrating the compass and setting up the Phantom properly using the Assist software. IOC settings for Course lock and Home Lock, Failsafe, Return to Home and Land, Alt. and Distance Limits as well. The Alt and Distance default settings are an astonishing 2000 meters! (That IMO, is way too high and far.)

    Also, today (Sept. 24th) was a difficult day to fly anyway, because of the magnetic interference coming from geomagnetic field disturbance activity in the atmosphere. I got a Kp-Index reading of 3-4 today which told me that the Actual Magnetic Field was "Unstable." So, I grounded mine for today until the solar activity settles down to a more reliable reading. Before I downloaded the Geomagnetic Storm App I found I too had unstable flights. Now, I check the readings from the app before taking off. When they're green it's safe. Yellow or Red, my Phantom stays on the ground.
     
  7. comanforterie

    Joined:
    Sep 24, 2014
    Messages:
    6
    Likes Received:
    0
  8. comanforterie

    Joined:
    Sep 24, 2014
    Messages:
    6
    Likes Received:
    0
    Is this the way the antenna is supposed to be on the Fc40?...see picture.....just those little wires hanging out? it would seem that something longer should be attached to them

    http://www.specialtystudio.com/ant.jpg
     
  9. lostkiwi

    Joined:
    Apr 4, 2014
    Messages:
    124
    Likes Received:
    0
    Location:
    UK
    Looks right to me.
     
  10. comanforterie

    Joined:
    Sep 24, 2014
    Messages:
    6
    Likes Received:
    0
    Thanks to everyone herein. I ran the Nazam software and drivers, and on site did a compass magnet calibration....it flew fine.
     
  11. Rustysocket

    Joined:
    Aug 22, 2014
    Messages:
    98
    Likes Received:
    0
    Good to hear.
     
  12. Cajvol94

    Joined:
    Jun 30, 2014
    Messages:
    217
    Likes Received:
    0
    The wires I have run almost the length of the landing gear. They are recessed into the legs and use the white tape that came in the kit to keep the wires in place and out of the way.
     
  13. mb_guy

    Joined:
    May 5, 2014
    Messages:
    91
    Likes Received:
    0
    Location:
    Winnipeg, MB. Canada
    That's also the same for me. Almost the length of the landing gear.