Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Firmware upgrade - It's all pants.

Discussion in 'Firmware' started by Hughie, Dec 28, 2014.

  1. Hughie

    Joined:
    Nov 22, 2014
    Messages:
    1,477
    Likes Received:
    141
    Location:
    Leeds, United Kingdom
    Is anyone having any grief with the latest H33D firmware upgrade.

    Not only does mine start at 45 degrees (previously it was face down, so arguably this is an improvement ?? :eek: ) but it is very intermittent and in fact does not want to tilt down at all really.

    I have redone the f/w flash, redone the TX calibration, redone the IMU advanced calibration.

    It's all pants.
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,416
    Likes Received:
    568
    Location:
    Sydney Australia
    Once again...

    Latest firmware makes gopro point 45 degs = good. Previous firmware had it pointing down and banging the table when initialising.

    As for tilt control...
    Start your RC assist and calibrate all sticks INCLUDING your X1/CH7. Close the RC assist and start the Phantom Assist and calibrate all sticks and X1/ch7. Then select "upgrade mode" to enable relative tilt movement.
     
  3. Hughie

    Joined:
    Nov 22, 2014
    Messages:
    1,477
    Likes Received:
    141
    Location:
    Leeds, United Kingdom
    Thanks Mako79. Not convinced I checked this was set.
    Hopefully that is the problem. Will redo this bit and report back.
    Cheers.
     
  4. Hughie

    Joined:
    Nov 22, 2014
    Messages:
    1,477
    Likes Received:
    141
    Location:
    Leeds, United Kingdom
    I had already set this of course, because it worked before the f/w upgrade.
    I went through the process again. Still no joy.
     
  5. Hughie

    Joined:
    Nov 22, 2014
    Messages:
    1,477
    Likes Received:
    141
    Location:
    Leeds, United Kingdom
    OK, so I tried to reflash the firmware 1.0.0.12 again, and got a bricked gimbal for my trouble.

    I have gone through the procedure three times for resetting the gimbal from bricked state:

    Short pins
    Turn on
    Green Led comes on and then goes Red/Yellow
    Assistant software sees Gimbal offers new firmware
    New firmware is updated, and says success! - recycle power
    Recycled power - gimbal is bricked again.

    Any clues please ?
     
  6. Hughie

    Joined:
    Nov 22, 2014
    Messages:
    1,477
    Likes Received:
    141
    Location:
    Leeds, United Kingdom
    Unbricking in previous post solved.

    What I had to do was reload the main controller firmware (it was already 3.08).

    When I started the reload the Phantom started beeping loudly every 1s (in a very distressed way!) and as the MC reload finished, the assistant software locked up and crashed :eek: . I cycled the Phantom power and re ran the assistant. The main controller details on the Assistant Upgrade page were gibberish (corrupt digits). I went ahead and redid the 3.08 load again, this time that reload worked.

    I redid the unbricking process of the gimbal which I had tried lots of time (see previous post), and after recycling it initialised and finally appeared on the Upgrade page.

    So I will now try again to cailbrate this pile of cack which calls itself a gimbal :eek:
     
  7. Hughie

    Joined:
    Nov 22, 2014
    Messages:
    1,477
    Likes Received:
    141
    Location:
    Leeds, United Kingdom
    OK. I seem to have the calibration cracked now.

    What seems to be happening is that in the Remote Assitant, when uncalibrated, the gimbal controls represented on the display are all over the place.

    When I press Calibrate they are smooth -1000 to +1000.
    When I click Next they are back to being all over the place.

    I redid this over and over, and on one occaision, after I clicked Next, the movement was also -1000 to +1000.

    No idea why, but something is very flakey, but that time it worked for me.

    Having reflashed the Main Controller firmware twice, unbricked the gimbal about 12 times and reflashed the gimbal about 5 times I am just happy to have something that works again. Oh yeah the gimbal knock on the desk is back again, but I will gladly take that all things considered. :?