Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Firmware mismatch?

Discussion in 'Firmware' started by Mactab, Jan 15, 2014.

  1. Mactab

    Joined:
    Nov 5, 2013
    Messages:
    105
    Likes Received:
    0
    Location:
    Ormskirk, West Lancashire
    Anyone help on this?
    I attached my PV to the computer this morning and its coming up with a message
    'you must update Main Controller firmware to new version'

    All my firmware appears up to date and indeed on the upgrade path it says 'No updates'

    Any ideas anyone?

    Main Controller Firmware : 1.08
    GPS: 6.0.1.3
    Receiver5.8G : 1.0.1.3
    P330CB: 1.0.1.19
    Battery : 1.6.0.0
     
  2. Mactab

    Joined:
    Nov 5, 2013
    Messages:
    105
    Likes Received:
    0
    Location:
    Ormskirk, West Lancashire
    Sorted.

    deleted and reinstalled the DJI software.
     
  3. Deepestblue

    Joined:
    Mar 26, 2014
    Messages:
    4
    Likes Received:
    0
    Hi Mactab,

    I have exactly the same idea and reinstalling the software and drivers several times didn't fix the problem. It always asks me to update the Main Controller Firmware but tells me at the same time it's uptodate and doesn't offer an option to update.

    Can you be so kind and detail what you did to fix this?

    Thanks!
     
  4. rjamesy

    Joined:
    Apr 15, 2014
    Messages:
    1
    Likes Received:
    0
    I had the exact same issue and this is what I did to get around it.

    There are two versions of Phantom 2 Vision Assistant Software v2.00 + v3.00. Originally I started with version 3 and tried to update the firmware but it would not allow me saying there was a firmware mis-match.

    So I uninstalled v3.00 and installed v2.00 and it allowed me to upgrade the main controller firmware.

    I uninstalled v2.00 and re-installed v3.00 and it allowed me to upgrade to the latest version.

    Hope this helps.