Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Firmware 3.12 warning. Do not update!

Discussion in 'Firmware' started by marcusdji, Mar 5, 2015.

  1. marcusdji

    Joined:
    Jun 7, 2014
    Messages:
    31
    Likes Received:
    0
    When firmware 3.10 was released I noticed the problem with IMU communication. It seems it was caused by a protocol problem. When the Phantom was hot it would not communicate the way it should with the other modules. Now the firmware 3.12 have the same problem, but now the phantom needs to be hotter. I already reported it to DJI, like I did when the 3.10 firmware was released.

    So my advice is: Do not update.

    Maybe they will allow the downgrade again, but meanwhile, you can downgrade to firmware version 3.08 using the Assistant v3.6.
     
  2. Geoffdb

    Joined:
    Feb 28, 2014
    Messages:
    7
    Likes Received:
    0
    Location:
    Miami, FL
    I agree...same problem...my gimbal is no longer functioning after 3.12 :( STAY AWAY

    I just got off the phone with DJI, rep said they've been getting a lot of these calls today
     
  3. eseckinger

    Joined:
    Feb 13, 2015
    Messages:
    231
    Likes Received:
    55
    Hmm, not having any issues with my Gimbal or Camera...
     
  4. Forester

    Joined:
    Oct 8, 2014
    Messages:
    54
    Likes Received:
    2
    Just upgraded! BIG MISTAKE! My controller kept showing error29 and ship wouldn't start up, and couldn't calibrate sticks. Tried controller from my other ship and same problem. Downgraded to 3.08 and all seems fine. When I upgraded I hit the upgrade all button. Bottom upgrade line was for zen? Don't know if that made a difference or not.
     
  5. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,544
    Likes Received:
    1,394
    Location:
    Salt Lake City, UT
    DJI screwed up a firmware update? What are the chances of that happening?

    (Just from being here a month, I'd say a solid 85% chance).
     
  6. SteveMann

    Joined:
    Aug 27, 2014
    Messages:
    1,977
    Likes Received:
    653
    Location:
    Westford, MA
    How do you do that?
     
    griter34 likes this.
  7. Forester

    Joined:
    Oct 8, 2014
    Messages:
    54
    Likes Received:
    2
    I always keep earlier assist versions. Opened last one and started over.
     
  8. jonstatt

    Joined:
    Feb 7, 2015
    Messages:
    65
    Likes Received:
    0
    This is not a universal problem though. I took the plunge and upgraded, and everything is fine for several flights. You must have the camera at version 1.30g if you don't already.
     
  9. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    I haven't had any issues either. I'm running latest camera firmware, didn't upgrade to 3.10 last time (so no rolling back required) but this one has been fine thus far for me on a Vision+ (original) and a P2...
     
  10. marcusdji

    Joined:
    Jun 7, 2014
    Messages:
    31
    Likes Received:
    0
    For people that are not having issues. What is your local temperature? The problem usually happens when your temperature is high. It is the same problem of the 3.10, but the temperature needs to be higher.
     
  11. jonstatt

    Joined:
    Feb 7, 2015
    Messages:
    65
    Likes Received:
    0
    Could you describe this IMU issue more? Are you talking about IMU calibration issues that are temp related, or actual flying? In the DJI assistant software the mod value for my gyroscope is 0.2 and the mod for accelerometer is exactly 1.00, so I am leaving any IMU calibration alone as there seems to be no need.
     
  12. marcusdji

    Joined:
    Jun 7, 2014
    Messages:
    31
    Likes Received:
    0
    No, I am talking about low level electronics protocol. Seems that with firmware 3.10 and 3.12 the internal communication between modules changed a little bit and they did not consider the small clock/data differences that occurs when the internal temperature changes. If the ambient temperature is hot and inside the Phantom is hot too, you may get a slow flashing yellow light and will not be able to fly at all. What you should consider is that it may get too hot when it is flying and start to read wrong IMU data and after that it could crash or flyaway.
     
  13. Fourblade

    Joined:
    Aug 9, 2014
    Messages:
    408
    Likes Received:
    67
    Location:
    Warwickshire UK
    I was one of the unfortunate sods that had the IMU initialisation error 25 immediately (the very second) after updating to v3.10

    I can assure you that here in the UK the ambient temperature is not very high. I can only think this error in 3.10 and maybe 3.12 is a bug in the firmware.

    As soon as I flashed to 3.10 (and I mean as soon as) I got the error and the red, green, yellow death star. Eventually I managed to fire it up without the red, green yellow but it would only fly one battery before needing to sit for at least 30 minutes - sometimes longer before the error would clear. This would suggest a temperature issue however it often did this from a cold start on a cold day?

    This is why I'm very twitchy about updating the firmware - 3.08 at least lets me fly :lol:
     
  14. eurostylin

    Joined:
    Feb 4, 2015
    Messages:
    32
    Likes Received:
    0
    roughly 3 hours of flying V3 on 3.12, no issues.

    Temperature hasn't been above 15F in a month.
     
  15. max

    max

    Joined:
    Sep 19, 2014
    Messages:
    199
    Likes Received:
    6
    I didn't think that was possible..... Are you sure your firmware was actually downgraded? Which version is listed in the assistant as being installed on your quad?
     
  16. marcusdji

    Joined:
    Jun 7, 2014
    Messages:
    31
    Likes Received:
    0
    Just install the assistant v3.6 and check the updates, you will see it shows the 3.08 firmware. From there you can downgrade.
     
  17. SteveMann

    Joined:
    Aug 27, 2014
    Messages:
    1,977
    Likes Received:
    653
    Location:
    Westford, MA
    Are you referring to the "NAZAM_2.20_Installer"? The version on the DJI websire is the same as I downloaded last October.
     
  18. max

    max

    Joined:
    Sep 19, 2014
    Messages:
    199
    Likes Received:
    6
    My understanding and first hand experience is that all 3.X assistant versions pull the same firmware from the DJI servers. Whichever firmware that DJI has designated as the current version. I have tested this myself. I was trying to go from 3.10 to 3.08 and it was impossible. All the 3.X assistants from the droneslinger website installed firmware version 3.10. Are you 100% sure you are able to do what you think you are doing?
     
  19. eseckinger

    Joined:
    Feb 13, 2015
    Messages:
    231
    Likes Received:
    55
    Another 2mile or so ground station mission down no issues. Temp 46F
     
  20. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,669
    Likes Received:
    5,710
    Location:
    Amory Mississippi
    I just went to 3.12 and tried it with no issues and came back in and just changed it back to 3.08 using the assistant 3.2 with no problems doing so . Glad I still had it in my downloads but I really didn't see any changes when calibrating or flying .
    The only thing that I don't remember seeing was it says nasa in app now where I just used to see N/A
     

    Attached Files: