Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

FCC mode, not sure if mine is working.

Discussion in 'General Discussion' started by Pickeringchris, Sep 17, 2014.

  1. Pickeringchris

    Joined:
    Sep 9, 2014
    Messages:
    30
    Likes Received:
    0
    In the videos I've watched when you turn the potentiometer all the way clockwise (FCC mode) this function is confirmed by a beep and flashing led on the controller when it's powered up. When I power on I still get the same led function as I did before. No flash and no sound. Maybe the new firmware is different and there is no flash or beep anymore. Can anyone confirm this? Thx
     
  2. HarryT

    Joined:
    Aug 4, 2014
    Messages:
    622
    Likes Received:
    0
    Location:
    Warrington, UK
    It only has any effect on the P2 Vision and Vision+. Does nothing on the original P2.
     
  3. ProfessorStein

    Joined:
    Jun 20, 2014
    Messages:
    1,136
    Likes Received:
    3
    Location:
    Portland, OR
    If you do, indeed, have a Vision series Phantom...

    As far as I can recall, the flashing green remains the same for both modes... it just indicates that it's linking. The only difference at RC start up between the two modes is it's two beeps for FCC, and just one beep for CE. Just sounds like your "beeper" is kaput.

    If you hook it up to the RC Assistant, it will tell you what mode it's in. Or fly it and you'll discover pretty quickly. CE has only half the range of FCC.


    EDIT: Yep, confirmed

    From http://wiki.dji.com/en/index.php/Phanto ... Controller
    Flashing is normal for both modes.