Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

FCC Mode / CE Mode Help

Discussion in 'Phantom 2 Vision + Discussion' started by iGot2Fly, May 3, 2014.

  1. iGot2Fly

    Joined:
    Apr 13, 2014
    Messages:
    6
    Likes Received:
    0
    I recived my Vision 2 + a couple of weeks ago and it has been working great, except there was two cases where I lost TX at around 600' - 900' away. It may have been because I was behind a large dirt mound. I wanted to check to see if this may have been because the controler was incorrectly set to CE mode. Turned the potentiometer on the back to the right and I did not feel resistance, so it spun past its limits. Could this mean the potentiometer is bad? I opened up the controler and verifited I have it set all the way to the right (clock wise) , and turned it so that it was not past its limts. When I start the controler, I get two beeps, and if I read correctly that means it is in FCC mode.

    Is there any other way to verify it is in FCC mode? I also looked in the manual and it said that the complience mode can be configured using the RC assistant software. I downloaded it and could not find that setting, does anyone know about that?
     
  2. Jayson Hanes

    Joined:
    Apr 6, 2014
    Messages:
    238
    Likes Received:
    0
    Location:
    Tampa, Florida USA
    connect the RC ASSISTANT software and verify your setting is on FCC in it as well
     
  3. KG4MXV

    Joined:
    Mar 29, 2014
    Messages:
    198
    Likes Received:
    1
    Your transmitter is set for FCC (the two beeps)

    How do you orientate your transmitter antenna.

    do you have it sticking straight up and out. if so that might be part of the reason.
    The way omni directional antennas work is that they radiate their energy from the sides of the antenna not the tip.

    So it is best to keep the antenna in a 45deg angle to the right or left doesn't matter.

    Also you also have to think about the radio wave, and its frequency. The control frequency is 5.8ghz (microwave)
    Higher frequencies do not like to travel though objects.
    So it make complete sense that you lost the control signal when you had a hill in between you and the craft.

    All the ranges are listed as line of sight. meaning that there is noting in between the transmitter and the craft but air.

    also make sure that noting has damaged the little antennas that are taped to the landing gear of the craft.
    there is a tiny wire protruding out of the end of each cable, that is the actual antenna. The bulge in the cable is a brass tube that is acting as what is called a Ground plane for the little antenna that is known as the driven element.
    It is very important that that driven element is not bent or damaged in any way.
    Both of them should look like this. ( yes there are two of them) And in the picture the craft is upside down.
     

    Attached Files:

  4. iGot2Fly

    Joined:
    Apr 13, 2014
    Messages:
    6
    Likes Received:
    0
    Thank you for the information! It was a really big mound of dirt, so it sounds like that was likely what was causing the problems. I just checked and they were not quite at 45 degrees, so I bent the two ends of the antennas a bit more to make sure they are at 45 degrees. The driven element looks good. I also was able to confirm I am in FCC mode. This time when I started the RC assistant the setting showed up (I think it was not communicating with the controller before)