Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

FC40 LED Error

Discussion in 'Phantom FC40 Discussion' started by JonP, Jun 14, 2014.

  1. JonP

    Joined:
    Jun 14, 2014
    Messages:
    3
    Likes Received:
    0
    Hi

    I bought a FC40 yesterday and assembled it this morning but cant seem to get passed a LED error code.

    I took a video of boot up here http://youtu.be/y2O96C87SnY

    Can any kind person tell me what I may have done wrong ?

    Many thanks Jon

    -- Apologies this is a first post and requesting help , I hope to be an active member once I have a quad to fly and can contribute !
     
  2. robinb

    Joined:
    May 10, 2014
    Messages:
    3,012
    Likes Received:
    527
    You are NOT getting full satellite reception.


    see page 30 of manual.
     
  3. JonP

    Joined:
    Jun 14, 2014
    Messages:
    3
    Likes Received:
    0
    Many thanks for that ! That was exactly what was wrong.

    But now I have a green flashing light but still cant power up the rotors ?
     
  4. robinb

    Joined:
    May 10, 2014
    Messages:
    3,012
    Likes Received:
    527
    Take off the props.

    Put the transmitter in atti mode (rh switch in middle).

    let it power up and then start the motors by bringing the 2 remotes to bottom inside 45 deg.

    release as soon as motors spin up
     
  5. JonP

    Joined:
    Jun 14, 2014
    Messages:
    3
    Likes Received:
    0
    Your a star ! I should have RTFM !

    You've save the weekend. Many thanks.. No to go play..
     
Loading...
Similar Threads - FC40 LED Error Forum Date
FC40 camera very detailed look (30+ pics!) Phantom FC40 Discussion Jan 28, 2015
I'd like my FC40 rear green leds to flash like a P2 Phantom FC40 Discussion Dec 13, 2014
Help please :) Installed tarot on fc40 with problem Phantom FC40 Discussion Aug 19, 2014
Hawks circled my FC40 Phantom FC40 Discussion May 24, 2014
Sticking with FC40, cancelled P2 kit order General Discussion Feb 26, 2014