Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

FC40 Firmware update (June 15)

Discussion in 'Firmware' started by DaveManton, Jun 25, 2015.

  1. DaveManton

    Joined:
    Jun 8, 2015
    Messages:
    5
    Likes Received:
    2
    Apologies for not having the firmware revision to hand but recently I calibrated my FC40 and it offered a firmware update. Knowing what horror can ensue I skipped it.

    Has anyone used this recent update and what was the outcome?
     
  2. sherpa

    Joined:
    Sep 28, 2014
    Messages:
    174
    Likes Received:
    13
    Location:
    White Lake, Mi
    What is the update number? I haven't seen one.
     
  3. Beario

    Joined:
    May 9, 2014
    Messages:
    355
    Likes Received:
    64
    Location:
    Hovering at 400 feet
    I tried it on my problem quad and all is well. Most likely it will be the final update for the FC40. The update is version 4.04
     
    IflyinWY likes this.
  4. sherpa

    Joined:
    Sep 28, 2014
    Messages:
    174
    Likes Received:
    13
    Location:
    White Lake, Mi
    Mine sez 4.02 is the most current. How Come?
     
  5. Beario

    Joined:
    May 9, 2014
    Messages:
    355
    Likes Received:
    64
    Location:
    Hovering at 400 feet
    IflyinWY likes this.
  6. IflyinWY

    Joined:
    Sep 12, 2014
    Messages:
    3,470
    Likes Received:
    939
    Location:
    Where the deer and the antelope play
  7. sherpa

    Joined:
    Sep 28, 2014
    Messages:
    174
    Likes Received:
    13
    Location:
    White Lake, Mi
  8. John C Jones

    Joined:
    Jun 24, 2016
    Messages:
    4
    Likes Received:
    0
    I am new to this all and my laptop is running windows 10. I have just purchased an FC40 and it flies really cool, thats coming from a total beginner by the way!! But can anyone tell me why after i have downloaded the Naza V2.40 it wont let my FC40 connect and therefore update.
    I was told when i bought it that iit hasn't had any updates and only flown approx 6 times am i right in thinking its my windows 10 stopping me, or am i still the numbskull that i think could be the problem??