Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

False Battery Percentage

Discussion in 'Standard/4k Discussion' started by kptw_pilot, Dec 28, 2015.

  1. kptw_pilot

    Joined:
    Dec 22, 2015
    Messages:
    59
    Likes Received:
    43
    Location:
    Pennsylvania
    I was about to fly my P3S, so I checked the battery inside. It was fully charged; 100%. Then I went outside and turned the controller and Phantom on, and all of a sudden it said that battery was 56%, and after running everything up and flying for a minute, it was down to 51%. I flew for about 14 minutes, but it mostly stayed at 51% for half the flight, then 50% until the end. The outside air temperature is 42 degrees Fahrenheit. This is the first time I've had this happen, but also one of the coldest flights it has done so far. Any ideas?
     
  2. joeb1999

    Joined:
    Dec 26, 2015
    Messages:
    118
    Likes Received:
    14
    Did you do the latest update?
     
  3. kptw_pilot

    Joined:
    Dec 22, 2015
    Messages:
    59
    Likes Received:
    43
    Location:
    Pennsylvania
    I have not, but I will likely do it shortly if that will solve the issue.
     
  4. joeb1999

    Joined:
    Dec 26, 2015
    Messages:
    118
    Likes Received:
    14
    Try the updates. Also make sure to all room temperature. If you use a battery after a fresh charge it can overheat. Gl hope it's just a minor thing.
     
  5. kptw_pilot

    Joined:
    Dec 22, 2015
    Messages:
    59
    Likes Received:
    43
    Location:
    Pennsylvania
    Just finished the update and re-calibrated. I have another battery charging. I'll charge it to 100%, wait a half an hour or so, and I will do the same thing and see if the percentage reads correctly; or at least more accurately.
     
  6. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,660
    Likes Received:
    369
    Location:
    Pacific,NorthWet, 97031
    How long had the battery sat before you used it? A day, a week or a weekday? Must have been a Weakday?:)
     
  7. kptw_pilot

    Joined:
    Dec 22, 2015
    Messages:
    59
    Likes Received:
    43
    Location:
    Pennsylvania
    It sat for only a few hours. I think it had to do with not updating. I haven't had the chance to fly it after I updated after the issue because the weather hasn't been great. I'll fly soon.
     
    #7 kptw_pilot, Dec 28, 2015
    Last edited: Dec 28, 2015
  8. kptw_pilot

    Joined:
    Dec 22, 2015
    Messages:
    59
    Likes Received:
    43
    Location:
    Pennsylvania
    The battery percentages are accurate now that it's updated. I'll post again if I have the same issue in the future, but for now it seems that the firmware update fixed the problem.