Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Factory firmware question!

Discussion in 'Pro/Adv Discussion' started by Karatekid1800, Jul 24, 2016.

  1. Karatekid1800

    Joined:
    Nov 26, 2015
    Messages:
    39
    Likes Received:
    2
    Hey guys, my p3p is 2 weeks old and it flies great! However, there is a small weird thing about my drone, the factory firmware of the remote is VERY old in comparison to the drone. Is this normal???
    What does 1.4.10+ stands for? 1.5.x? Cause I do have the ability to record in 2.7k(which offered for the first time in 1.5.x), and if it's really 1.5.x isn't it an unstable firmware???
    One more thing, I keep getting warning messages from that app saying that the aircraft, controller and camera require an update.

    The drone is flying great! I don't have any intention to update it, but if this out of the box firmware combination in not safe, then please let me know

    [​IMG]

    Thanks
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,842
    Likes Received:
    5,549
    Location:
    US
    Yes.

    It means you're running something newer than 1.4.10 -- most likely one of the 1.5 releases.