Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

extender issues

Discussion in 'Phantom 2 Vision Help' started by plantman, Nov 4, 2014.

  1. plantman

    Joined:
    Oct 23, 2014
    Messages:
    4
    Likes Received:
    0
    Newbie here, I've had my P2V for almost two weeks now. I've been flying pretty conservatively until I build up my chops. I've hit my ceiling limit (400') several times, but don't take it more than a couple hundred feet away. Today was my first flight using NAZA controls, everything worked as advertised. I finally read a good piece about setting up for this, if I hadn't I probably would not have changed S1 P3 to failsafe and would have had my first crash. Anyway, with my newfound confidence in having multiple failsafe options I thought I would get a little braver in my flying. At a little over 300' away and about 60' up I lost my video. In troubleshooting this today with a WiFi scanning app. the extender showed up once and then disappeared, never to appear again, in the app. or on my iPad mini. Could it be that I have been flying all this time directly connect to the Phantom and not the extender? When I updated to 3.06 I started to have video issues that was seemingly correct by lowering my resolution. I'm now starting to think this was just a bandaid and that my extender is not functioning properly. Any thoughts are greatly appreciated. Thanks
     
  2. burlbark

    Joined:
    Oct 6, 2014
    Messages:
    502
    Likes Received:
    16
    Have you charged it? I know it should be obvious but its not to some. You need to plug it in to usb and leave it there for several hours.
     
  3. plantman

    Joined:
    Oct 23, 2014
    Messages:
    4
    Likes Received:
    0
    yup, always keep it charged