Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

ESC Issue--Need Help Please

Discussion in 'Phantom 2 Vision + Help' started by npalen, Jul 21, 2014.

  1. npalen

    Joined:
    Mar 12, 2014
    Messages:
    532
    Likes Received:
    8
    Location:
    Kansas
    I replaced an ESC on my Vision Plus today as the lights were not working on that ESC. Now I'm getting a series of four red flashes with beeps from the new ESC when powering-up. Also noticed a very slight twitch in the motor during power-up kind of like a thoroughbred wanting out of the starting gate. The bird flies and hovers fine and shows the normal red lights on the front during flight which is where the new ESC is located.

    This is the ESC that I installed:
    http://www.ebay.com/itm/DJI-Phantom...ol-/351081274008?ssPageName=ADME:L:OC:US:1120

    I'm wondering if there was a recent update to the ESC's that displays the power-up sequence mentioned above. Anyone with a fairly recent new Vision Plus that's seeing the four red flashes with beeps? Thanks for any help or tips.
     
  2. AAG201

    Joined:
    Jul 22, 2014
    Messages:
    4
    Likes Received:
    0
    Well, I wish I could help, but rather I am having the exact same issue (on the same day). I replaced an ESC today due to low torque/fail to start at one corner and now I have the same symptoms you've described. I've only had my Phantom 2 Vision+ for about ten days and already had an issue. With the new ESC, I get the normal four loud beeps followed by four soft beeps. The Phantom flies normal now, but I can tell there is still low torque at this motor. If you remove the props, can you tell if you also have low torque at this motor? Like yours, mine flies fine. The low torque is only at idle.
     
  3. npalen

    Joined:
    Mar 12, 2014
    Messages:
    532
    Likes Received:
    8
    Location:
    Kansas
    I didn't notice any difference in torque but will check again with that in mind. Hopefully we can get to the bottom of what's causing this. Good to know that it's not just me. :)
     
  4. npalen

    Joined:
    Mar 12, 2014
    Messages:
    532
    Likes Received:
    8
    Location:
    Kansas
    I think I can feel a little bit less torque on the motor with the replacement ESC at least at low RPM.
    You mention the "normal four loud beeps", did your original ESC do that also? Did you replace a rear or front ESC?
    I don't get the four loud beeps with red flashes on the original front ESC just with the new one.
    That's what makes me think that the "new" ESC's have a different startup format than the older ones. The thing is that we really don't know what's "new" and what's "old". The replacement ESC's could have been in stock for several months.
    Another thing I don't understand is whether the red blinks and beeps originate in the main control unit or the ESC.
    The label on the box in which the ESC came shows "Phantom 2 VISION Spare Part NO. 7 ESC with a part number PV645411812.
     
  5. AAG201

    Joined:
    Jul 22, 2014
    Messages:
    4
    Likes Received:
    0
    I misspoke earlier... I used to have four loud beeps, but now there are just four soft beeps. Perhaps this is just an older ESC that I installed as my Phantom just shipped from China about two weeks ago. The good news is that it seems to be flying well today. Part number 7 is correct for the P2V. I bought two ESCs and I have a spare motor so I may try to solder that up and install it the next time I have the Phantom apart.
     
  6. Double-D

    Joined:
    Jun 6, 2014
    Messages:
    319
    Likes Received:
    0
    Location:
    The Land Down Under
    I replaced an ESC the other day and it now gives me 4 extra beeps and flashes on that ESC at startup.
    She flies fine and I'm sure I have seen a video showing the same.
    I just except it as a battle scar :)
     
  7. cmturn0

    Joined:
    Aug 6, 2014
    Messages:
    27
    Likes Received:
    0
    Of the 3 Phantom's I currently have (2) are vision plus's and one is a regular vision. The front 2 ESC's on the vision make the beep, and none of them do on either of my vision plus's. The regular vision was a parts donor for a while and I swapped a front ESC from the vision to the plus and the beep moved with the ESC. I have since swapped them back because it turned out the ESC wasn't the problem & the beep is super annoying to me, and the beep again followed the ESC. Based on that I suspect that there a was change in the plus/newer version ESC's and they no longer beep. I have tried to look through YouTube vids to compare vision to vision plus startups to look for said beep, but haven't had much luck as I couldn't find many that include the start-up sounds in the videos...