Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Error 33 ?

Discussion in 'Phantom 2 Vision + Discussion' started by erikgraham, Dec 1, 2014.

  1. erikgraham

    Joined:
    Nov 4, 2014
    Messages:
    226
    Likes Received:
    9
    Location:
    New York and Philadelphia
    Whenever I launch the Phantom software, I get Error 33. See attached image. Anybody have any idea what this is?

    Background:

    This is a brand new, never been flown Vision+ (Version 3).
    So far, I have:
    1. Unboxed it and connected to my Mac.
    2. Run the Phantom software to update firmware (most was already up to date).
    3. Switched to Naza mode.
    4. Run the RC Assistant
    5. Calibrated the gimbal (per Mopar Bob viewtopic.php?f=39&t=30479)

    I have NOT calibrated the compass. Haven't had a chance to yet.

    The error came up the very first time I connected the Vision+ and launched the Phantom Software. It has come up every time.
     

    Attached Files:

  2. erikgraham

    Joined:
    Nov 4, 2014
    Messages:
    226
    Likes Received:
    9
    Location:
    New York and Philadelphia
    Well, it looks like Error 33 has something to do with the battery. At least it wasn't Order 66. I swapped batteries and I'm not getting the pop up window anymore. I'll have to look into this some more, but I don't think I'll be flying with that battery ever again.
     
  3. Djraffa

    Joined:
    Sep 12, 2014
    Messages:
    5
    Likes Received:
    0
    Battery cell damaged