Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Dreaded ribbon cable and failed repair

Discussion in 'Zenmuse H3-3D/H4-3D GoPro Gimbal' started by Ohary, Sep 19, 2014.

  1. Ohary

    Joined:
    Apr 20, 2014
    Messages:
    205
    Likes Received:
    7
    Noticed my go pro was not porting video to fpv monitor. Upon inspection the ribbon cable was sheared. We all know this is almost expected with the flimsy nature of a ribbon cable, but now with replacement of the cable, the gimbal acts dead as soon as I connect it to the go pro with said dreaded replacement ribbon cable. Works fine in balancing in all 3 axis, but as soon as I plug in the ribbon cable to the go pro it dies immediately and the back plate (which contains some electronic components) heats up HOT! Something is obviously wrong. Any help appreciated!
     
  2. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Flip the ribbon cable around...what you're experiencing is the result of connecting it backwards (each end is in the wrong port)
     
  3. Ohary

    Joined:
    Apr 20, 2014
    Messages:
    205
    Likes Received:
    7
    Problem solved!!!

    Dunce award to me. Apparently when the ribbon tears, it's easy to install backwards.

    Thank you so much! (I thought I was in serious trouble)
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    No problem!

    Guess how I know about that ;)