Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Downgrading FW 1.5 to 1.4 Help please

Discussion in 'Pro/Adv Discussion' started by Cynical, Jan 26, 2016.

  1. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Hi guys.
    Ok im gonna try and downgrade my P3P to firmware 1.4. But i would love some help so i minimize the chance of bricking it.
    I downloaded the FW file from Phantomhelp DJI Phantom Accessories & Tips - Phantom Help

    Filename is: P3X_FW_V01.04.0010

    I accually tried to just pop it in the drone and power it on. That didnt work. Nothing happend.

    Could anyone tell me how to do this correctly. Was so sure i saw a step by step. But i havent seen it and searched like mad.

    Humble thanx
    /Cyn
     
  2. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    Place the 1.4.10 BIN file in the ROOT DIRECTORY of your Micro-SD card. Power on the aircraft & in a few moments the update should proceed. Gimbal will chirp & LED will flash red/green during update process. When complete you will hear a D...DDD chirp & the gimbal light will be solid green. After update check result text file on Micro-SD to confirm success.

     
  3. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    Dont happen. It stays silent and green solid light. Im confused
     
  4. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    Were you on 1.6 before 1.5? I was and nothing was able to bring it to 1.4. I tried the sploodge method countless times, and in different ways but nothing worked.
     
  5. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    I was at 1.5 :/


    Sent from my iPhone using PhantomPilots mobile app
     
  6. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    If you were never on 1.6 you're in luck.
     
  7. Cynical

    Joined:
    Jan 11, 2016
    Messages:
    46
    Likes Received:
    6
    I thought i bricked it yesterday. But managed to get it to work again.. i hope. But until I tried to update to 1.6 the RC and aircraft didnt connect. Just flashing red like crazy.. So im out of luck for good with the 1.4 dream.
    Starting to wonder if i upgradet to 1.6 then back to 1.5 or something the first day without rememering it. Cos nothing did work.

    I tried the method where you push in the little button on the side of the aircraft when starting the drone with firmware inside.
    Went dead lol.
    Tried everything to get it to work. But until i tried with 1.6 it was a brick.

    I think everything is ok now tho
     
  8. raydengt2000

    Joined:
    Dec 11, 2015
    Messages:
    24
    Likes Received:
    0
    Hello,

    What if I was at 1.6, install the 1.7beta FW, then go down to 1.5(since the beta is backward compatible), then go down to 1.4. Did anybody try this yet?
     
  9. Shaiful Rizhuan

    Joined:
    Jan 12, 2016
    Messages:
    104
    Likes Received:
    27
    If you ever been in 1.6, you can't go to 1.4. You are welcome to try it.