Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Do I have to install firmware updates chronologically?

Discussion in 'Phantom 3 Help' started by Nola, Feb 16, 2016.

  1. Nola

    Joined:
    Jan 29, 2016
    Messages:
    5
    Likes Received:
    0
    I need to update my firmware and the version I have installed is old 1.1.9.
    Do I have to install 1.3 then 1.5 then 1.6 or can I just update to the most recent update immediately?
    Thank you for your time.
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,850
    Likes Received:
    5,556
    Location:
    US
    You need to install 1.3 and then you can jump to 1.6. If needed, you can find detailed firmware installation instructions here.
     
  3. Nola

    Joined:
    Jan 29, 2016
    Messages:
    5
    Likes Received:
    0
    Thanks so much for the quick reply!