Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI V2 plus calibration problem

Discussion in 'Phantom 2 Help' started by Pascoe, Apr 19, 2015.

  1. Pascoe

    Joined:
    Apr 16, 2015
    Messages:
    11
    Likes Received:
    2
    Location:
    Wales
    Please could some kind person help me. I had a small accident with my V2 Plus in that on take off it tilted and fried the speed control printed circuit board which I replaced including the motor. The problem now is that I have 2 solid red lights on the front of the copter indicating a calibration problem. I have up to 8 sats connected to my mobile but no matter how I try to calibrate they do not change. I have double checked the connection to the top shell and it is fine. The copter has been used for about an hour all told as we have not had much good weather since I bought the drone last December. I would appreciate any help as I am becoming a little desperate to try the drone out after spending more than a grand. Many thanks
     
  2. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,684
    Likes Received:
    5,713
    Location:
    Amory Mississippi
    Welcome to the forum Pascoe :)
    Have you done an advanced IMU calibration in the assistant program ? You say you have tried to calibrate but not what type .
     
  3. Pascoe

    Joined:
    Apr 16, 2015
    Messages:
    11
    Likes Received:
    2
    Location:
    Wales
    Thank you for the reply, I carried out the
    advanced calibration and also a couple of physical ones. It would appear that a solid red Led on the front of the copter may not be calibration after all.i have read that someone else had a similar problem that indicated a motor problem but they are all fine.do you think I am safe to fly. You may have guessed I am new to the drone world but am willing to learn and appreciate you're time. Today would be a good day to fly as it is sunny herein Wales
    ,
     
  4. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,684
    Likes Received:
    5,713
    Location:
    Amory Mississippi
    I wouldn't advise it if you not getting the lights right .JMO
    I would try and do the advanced calibration and compass one again and see what I got . Sometimes it take several attempts on some to get it right .
    I would not send mine up and chance it !!
     
  5. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,118
    Likes Received:
    405
    Location:
    Commerce Twp,MI
    Those two solid red LED's indicate the front of you craft and they only go red when the motors spin up for takeoff. When you first start the battery those front LED's will flash red three times then go from green, yellow and red then off. Try it by holding up your P2 and watching those front LED's while turn the battery on.
     
    dirkclod likes this.
  6. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,118
    Likes Received:
    405
    Location:
    Commerce Twp,MI
    Morning Dirk fall out of bed this morning or you puten on you're going to church rags on.
     
    dirkclod likes this.
  7. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,684
    Likes Received:
    5,713
    Location:
    Amory Mississippi
    Both ;) Morning bro and thanks for looking in on this ;)
     
  8. Pascoe

    Joined:
    Apr 16, 2015
    Messages:
    11
    Likes Received:
    2
    Location:
    Wales
    Thank you very much for you're reply, I have carried out the checks and calibration you suggested but the red LEDs will not turn off. Should I be concerned?
     
  9. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,684
    Likes Received:
    5,713
    Location:
    Amory Mississippi
    Pascoe I think we are misunderstanding each other. You going to have red lights on in front . If all looks good in your app and it spools up then take it up a little and let it hover to see .That's just what I would do BUT THAT'S JUST ME !!
     
  10. Pascoe

    Joined:
    Apr 16, 2015
    Messages:
    11
    Likes Received:
    2
    Location:
    Wales
    Thanks for the info. I will give it a try the worst that can happen is its bye bye (hopefully not)
     
  11. Anything4apicture

    Joined:
    Jan 25, 2015
    Messages:
    9
    Likes Received:
    0
    When in doubt TEATHER your drone to a brick. try to power up the motors with on props first. Run up the power see if the front lights change......m
    Good luck!
     
  12. Anything4apicture

    Joined:
    Jan 25, 2015
    Messages:
    9
    Likes Received:
    0
    Oops .... Try to power up the motors with NO props first.
     
  13. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    10,684
    Likes Received:
    5,713
    Location:
    Amory Mississippi
    I just went out and took a spin and the red lights stay on Pascoe on the front when all is good .Solid red lights




    like this
    h.jpg
     
    #13 dirkclod, Apr 19, 2015
    Last edited: Apr 19, 2015
  14. Pascoe

    Joined:
    Apr 16, 2015
    Messages:
    11
    Likes Received:
    2
    Location:
    Wales
     
  15. Pascoe

    Joined:
    Apr 16, 2015
    Messages:
    11
    Likes Received:
    2
    Location:
    Wales
    Thanks for the info,everything seems to be ok now. Crisis averted!!
     
  16. Pascoe

    Joined:
    Apr 16, 2015
    Messages:
    11
    Likes Received:
    2
    Location:
    Wales
    That's great thanks for the info. Every thing seems ok. Thanks to every body that took the time to help
     
    dirkclod likes this.