Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI Phantom Motor Has Stopped Working!

Discussion in 'News' started by boeingjetjock, Mar 2, 2014.

  1. boeingjetjock

    Joined:
    Mar 2, 2014
    Messages:
    3
    Likes Received:
    0
    Help! Help! Help!

    I have had my DJI Phantom since November 2013 and to date have never had a problem (or a crash)!

    One of my motors has stopped working!

    The other 3 motors are running normally and the fourth motor just spins very, very slowly!

    What has caused this and what can I do?

    Cheers .........
     
  2. syotr

    Joined:
    Jul 30, 2013
    Messages:
    895
    Likes Received:
    134
    Rotate the motor by hand. Does it feel different than the others? Could be a bad bearing. Can you move it up and down? Retaining clip may have come off. Sometimes they get pulled up into the motor and stick to the magnets. There could be other grit or something in the motor. Does it get hot when you run it?
    It could be a wire loose inside the Phantom body. You will have to open it up to see. The ESC (electronic speed control) for that motor could have failed. Motors and ESC's are cheap and easy to replace if you have basic soldering skills.
     
  3. boeingjetjock

    Joined:
    Mar 2, 2014
    Messages:
    3
    Likes Received:
    0
    SYOTR

    Thanks - I'll try your suggestions ......
     
  4. boeingjetjock

    Joined:
    Mar 2, 2014
    Messages:
    3
    Likes Received:
    0
    SYOTR
    Motor rotates by hand and feels no different to the others ....... Could be a bad bearing as you suggested!. It doesn't move up and down? Can't tell if it gets hot when I run it as it won't run!

    Guess it may be a loose wire inside the Phantom body.

    I'll take it to my local Phantom dealer and see if they can fix the problem .....

    Cheers ...........
     
  5. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,374
    Location:
    Live! From New York!
    I have noticed the OEM motors have copper windings that look like a 3 year old wrapped them.
     
  6. thongbong

    Joined:
    Aug 3, 2013
    Messages:
    499
    Likes Received:
    11
    Esc died. Happens a lot with RC motors. Easy fix.
     
  7. Dalite

    Joined:
    Jan 19, 2014
    Messages:
    159
    Likes Received:
    1
    Location:
    Brunswick, GA. USA
    As a wild guess, fire up the NAZA Assistant to be sure it hasn't glitched itself into believing it is a tri-copter configuration.

    If so, it will only power 3 motors fully, but apparently the quiescent point of the fourth motor is not preventing it from trying to spin.

    If you find this to be the case, and others confirm the same thing, we may have an answer to the pitching to one side and flying away that seems to always be explained away as pilot error.
     
  8. Elginet

    Joined:
    Dec 16, 2013
    Messages:
    178
    Likes Received:
    1
    Location:
    Illinois
    Check all the solder joints from the esc to the main board. Something came loose.
     
  9. karatkij

    Joined:
    Feb 6, 2014
    Messages:
    20
    Likes Received:
    0
    Fellow P2V hobbyist suggest contacting dealer Atlanta Hobby, which will not do anything after box is opened. Once you test the P2V, and is not working right will direct all cash sales that they make to DJI . No tec support. They have no faith in the product, only the money.Amazon.com at least backs the product (if not working correct). A hard lesion learned.
     
  10. nicophantom

    Joined:
    Mar 26, 2014
    Messages:
    5
    Likes Received:
    0
    Heeeelp!! Heeeelp!!

    My motor has also stopped working!!! what can I do? It gets REALLY REALLY HOT!! WhenI power on the phantom all motors run except one and that arm's led does not light up also... I have changed the Naza ports in order to see if it was the naza or the esc/motor... but when I did the other motor worked fine! How can I know if it is the ESC or the motor?? All the wires seem to be in good condition and well connected!

    All this happened after a crash today...

    Help me please!Help me please!Help me please!