Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI P3P orange blinking link OFDM LED

Discussion in 'Pro/Adv Discussion' started by Jesolins, Jun 7, 2016.

  1. Jesolins

    Joined:
    Jul 29, 2014
    Messages:
    55
    Likes Received:
    0
    Hi Gents,
    I have a P3P that will not link. The OFDM link LED blinks orange and will not blink red to link when the link button is pressed. Any ideas as to what causes this? The firmware was updated a few days ago. It flew fine several times with no hard landings the day before...
    Cheers,
    Jim
     
  2. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,530
    Likes Received:
    1,478
    Location:
    Sacramento CA
    Maybe you didn't set the RC to link before pressing the link button on the AC?

    Follow these steps:
    Phantom3 Link Remote Controller - Phantom Help
     
    JoBe likes this.
  3. Jesolins

    Joined:
    Jul 29, 2014
    Messages:
    55
    Likes Received:
    0
    Yes thanks I did that and also tried to do the manual link without using the Go App too. What does the orange LED mean? On my other P3Ps it is only green and red, never orange.
     
  4. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,530
    Likes Received:
    1,478
    Location:
    Sacramento CA
    Dont know for sure. If I were to guess it would be the AC is seeing something it doesnt understand from the RC. You said you updated the AC FW recently. If it was to 1.8, the RC must be at 1.6 due to the encryption change. Perhaps one of those FW updates was not fully completed. Again, just guessing so will happily defer to someone who knows more.
     
    #4 Oso, Jun 7, 2016
    Last edited: Jun 7, 2016
    JoBe likes this.
  5. Jesolins

    Joined:
    Jul 29, 2014
    Messages:
    55
    Likes Received:
    0

    Hi and thanks again. The firmware has been successfully updated on both the RC and Quad. I can link that RC successfully with my other P3P's so it is not the problem. The P3P OFDM LED blinks orange before and after the linking button is pressed. It should be blinking red. Not sure what orange means but it will not link with any RC.
    Cheers,
    Jim