Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI GO will not start after install Litchi

Discussion in 'Pro/Adv Discussion' started by dropke, Mar 26, 2016.

  1. dropke

    Joined:
    Jul 25, 2014
    Messages:
    80
    Likes Received:
    1
    Location:
    Antwerp
    I use them together for some time now.

    Wenn I try to start DJI Go I DO NOT get (android 6.0.1) 'the choice between DJI GO or Litchi USB4
    choice anymore.
    Even if I pushed DJI GO to start my Nexus 6P android 6.0.1 starts in LITCHI.
    How can I force my USB connection to let me chose ?
    Is it an Android known Error ?
    I tried to change in setup 'USB error debug' , but No differnce
    Anyone suggestions ?
    tnx
     
  2. Tim in Florida

    Joined:
    Jan 2, 2016
    Messages:
    113
    Likes Received:
    30
    Is it starting Litchi automatically or nothing will start?
     
  3. dropke

    Joined:
    Jul 25, 2014
    Messages:
    80
    Likes Received:
    1
    Location:
    Antwerp
    Instead of DJI GO starts Litchi automacialy.

    On my Nexus 10 android 5.1.1 it is working Normal
    if I push DJI Go it start DJI GO but before staring I can chose between USB DJI GO or Litchi USB
     
  4. Tim in Florida

    Joined:
    Jan 2, 2016
    Messages:
    113
    Likes Received:
    30
    OK... I have had this same problem. You need to clear the defaults in Android. I will do a screen shot video and show you how to fix it if my explanation is not good enough. This is a frustration I have with Android. It sets a default and then you have to manually remove it. But, here is what you must do:

    1. Make sure you have both apps closed. You can do this in Android or you may have a Task Killer app. I use Zapper Task Killer
    2. Open your application manager
    3. Select Litchi
    4. Select CLEAR DEFAULTS (if there are no defaults set, it will be (greyed out and you can't select it). This should fix it.
    5. Do the same for any other flying apps you have (DJI Go, Vertical studio, Altizure, etc.)

    With all apps closed, have your phone plugged in to the DJI remote controller. Turn on the controller. It should let you pick which app to use. It may set that app as default so you may have to do this process whenever you want to switch between apps. There may be a way to keep it from making a default but I am not sure how to do that.

    I have to go have breakfast with my wife, now. I will check this thread in am hour or so and make a how-to video if you need me to.
     
  5. dropke

    Joined:
    Jul 25, 2014
    Messages:
    80
    Likes Received:
    1
    Location:
    Antwerp
    Tnx for the info.........I will try it and let You know if it solves also my Problem on my Nexus 6P
     
  6. dropke

    Joined:
    Jul 25, 2014
    Messages:
    80
    Likes Received:
    1
    Location:
    Antwerp
    Yes this is the Solution..................tnx
    Maybe here are some Android specialist wo can give an continious solution for Android users so
    that I ALWAYS get the indication
    " Chose an APP for your USB apparatus'
    DJI Go
    Litchi
     
  7. Tim in Florida

    Joined:
    Jan 2, 2016
    Messages:
    113
    Likes Received:
    30
    I am glad it worked. I also hope for a REAL solution so we can choose each time. IMG_1060952924250063.jpeg
     
  8. ScopeTech

    Joined:
    Nov 21, 2015
    Messages:
    221
    Likes Received:
    59
    Pretty simple, follow the instructions posted earlier to clear your defaults, and when you next plug in your device and it pops up to choose your app, make sure you don't choose the option to set it as default.
     
  9. Tim in Florida

    Joined:
    Jan 2, 2016
    Messages:
    113
    Likes Received:
    30
    I do not get an option to "Set as Default". I wish I did. I have to go to the application manager and clear defaults from whatever flight program I last used in order to get a choice to use a different one. See below for what I get now that I have cleared defaults: