Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard DJI GO video feed lost after 80m away

Discussion in 'Phantom 3 Help' started by Scott Shuldiner, Feb 17, 2016.

Tags:
  1. Scott Shuldiner

    Joined:
    Jan 13, 2016
    Messages:
    3
    Likes Received:
    0
    Hello,
    I had many flights in my first 2 weeks of my Phantom 3 Standard and it worked beautifully. Could get to the advertised 500 meters with perfect video feed to my iPhone 6. I had a minor crash and my RC antenna broke, so sent it back to DJI. They repaired it and sent back. Now, I can connect everything fine but I lose video feed and get a "no connection" indicator on the DJI GO app when I fly more than 80 meters away. I can still control the drone with the RC to ~500 meters, but not being able to see anything on my phone is not as fun!

    Other stuff:
    *tried using my iPad and replicated the same issue, so it's not the iPhone 6.
    *when I got the drone back, I didn't get any indicator that I needed to update firmware in the app, so I assume it is up to date.
    *I already tried re-linking the RV to the aircraft and re-installing the DJI GO app

    Anyone have any ideas what it could be?

    Thanks in advance.
     
  2. gklugie

    Joined:
    Dec 12, 2015
    Messages:
    146
    Likes Received:
    50
    Location:
    Dallas, Texas
    I was losing signal at shorter distances than yours. I was able to solve it by be-binding the controller to the bird.
     
  3. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,660
    Likes Received:
    369
    Location:
    Pacific,NorthWet, 97031
    Does the Live video come back when you get closer?

    Do you loose Telemetry?
     
  4. gklugie

    Joined:
    Dec 12, 2015
    Messages:
    146
    Likes Received:
    50
    Location:
    Dallas, Texas
    I never lost video or telemetry. I only got a lost signal warning.