Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional dji GO stopped working...

Discussion in 'Phantom 3 Help' started by LaChassagne, Sep 12, 2015.

  1. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    Hi,

    Today I tested out my P3 professional for the first time. All updates, etc. were done and instructions were followed, and the first try was successful. I have used the P3 and RC in combination with a Samsung Galaxy Tab 3 tablet with Android 4.4.2.

    Later on today I wanted to give it another spin, powered it all up, but the dji GO app would boot. The app starts to load, but then gives me the message: 'dji GO has stopped'.

    After several unsuccessful tries to reboot it, I have uninstalled the app, downloaded it anew from the dji-website, installed it again, but to no avail...
    I have no idea why the dji GO app does not start up anymore. Any ideas? Suggestions?

    Cheers! :)
     
  2. Phil Tuggle

    Joined:
    Jun 29, 2015
    Messages:
    145
    Likes Received:
    53
    Location:
    Sumter SC USA
    Anytime you want to fly,
    Disable Google Play Services.
    Turn off WiFi.
    Go into Airplane Mode, even if that sounds silly.
    That should do it for you.
     
    nickyb and bobmyers like this.
  3. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    Thanks, Phil, I'm going to give that a try!

    Because the problem is still not solved. Here is what I did in the meantime: I deleted all dji related files using ES File Explorer on my tablet. I then downloaded the app again from the dji website and installed it. I was then able to start up the app normally again.

    I took out the P3 for a flight today (the app told me I needed to update the firmware, while I have all latest updates already on the P3 and RC, though. So I didn't do anything with it). Anyway, after a nice flight, the P3 rotors were powered down, but the P3 and RC and tablet were left on. After maybe a minute or so, the dji GO app stopped working again, just like yesterday...

    So, I did not solve the problem yet. Again I cannot open the dji GO app. (I do not want to keep on uninstalling the app and re-installing it after every flight, obviously).

    I will repeat the uninstall - reinstall procedure and will then also Disable Google Play Services, Turn off WiFi, and Go into Airplane Mode as per your suggestion.

    I hope that'll do the trick. I'll let you know!

    Cheers
     
  4. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    Update
    I uninstalled the dji GO app again, reinstalled it, and turned off WiFi, went into Airplane Mode, but was unable to disable Google Play Services. GoogleLocationService and I believe PendingIntentCallBackService were started by some application on the tablet almost immediately after I had stopped those services.

    I went ahead anyway, and was able to start up the dji GO app again, and took the P3 for its 3rd flight. But because a couple of rain drops started to fall out of the sky, I broke off the flight, the rotors were powered off, but I left the P3, RC and tablet on. This time the dji GO app stayed on! Hurray, I thought, and a couple of minutes later, when it was dry again, I started the 4th flight.

    When there were approx. 5 minutes fly time left, the dji GO app stopped working again (message: "dji GO has stopped"), while I was able to keep on flying and land the P3. After that, I was not able to load the dji GO app anymore, just like before.

    So, I'm not sure that I have really made any progress in solving the app problem, here...

    Any ideas are welcome!
     
  5. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    Update
    Without uninstalling and re-installing, I got the app to boot again. I simply deleted the flight record and the mp4-recording in the folder DJI --> dji.pilot --> 'DJI_RECORD'-map. (Note: because I deleted the two files at the same time, I do not know if both need to be deleted or just one of them, to be able to boot the dji GO app again).

    In the dji GO app itself, I change the settings of the 'video cache' so that 'cache locally when recording' has been turned of. Hopefully, that'll prevent the mp4-version of the recording being made and saved on the tablet while flying. As I think that this is somehow causing the problem: the cache becoming to full.

    I'll give the P3 another try, to see if this indeed has solved the problem.
     
  6. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    Another update.
    I took the P3P for a flight after having done as described in the update above. After some time, the app stopped working, while the P3P was still in the air. I landed it without a problem, and turned off the rotors.

    This time, the app was not completely off, and -I think after I clicked away the popup message 'dji GO has stopped', the app showed, but mostly in grey scales and with a 'disconnected'-message where normally the 'safe to fly'-message is shown.

    Since I made the changes in the settings of the app, no mp4-file was recorded on the tablet and I am able to boot the app. Which is nice.
    I've got the feeling that the problem that I experienced this time, might be a different problem..(?)
    (Their are quite a lot complaints all over the internet about connectivity problem).

    So, things are still far from how they should be. Any suggestions are welcome!
     
  7. Phil Tuggle

    Joined:
    Jun 29, 2015
    Messages:
    145
    Likes Received:
    53
    Location:
    Sumter SC USA
    Here is a poster on another forum who described his problem similar to yours, but only when beginning to record video, and he recently put this up: (but I think you already tried this)

    ****CAUSE FOUND****
    It is definitely the symptoms above causing the repeatable crashing, if you go into settings and set "cache locally when recording" to OFF, you no longer get the crash, so it is DEFINITELY a bug in the DJI Go app when it tries to access locally cached video files. I wonder if anyone at DJI takes notice of this stuff? - dion.lazerlight on the DJI P3 forum thread-28429-1-1 Aug 18

    As for myself, I am stumped, unless it is somehow video related. Like 2GB limit reached, or something like that.
     
    #7 Phil Tuggle, Sep 14, 2015
    Last edited: Sep 14, 2015
  8. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    Thanks for the reply, Phil, appreciated!

    I think I might have solved it. That is: YOU probably have solved it, Phil! Because I finally found a way to turn off Google Play Services on my tablet after all. And this seems to be crucial, both in terms of -suddenly- very smooth display of the P3P camera feed and in terms of the app no longer crashing (so far -a couple of flights later- anyway). I've got to say, next to turning off Google Play Services, I also followed the advice from someone else of turning off the tablet completely in between flights. That might have had an effect as well.

    I hope this all has solved it.
     
  9. Phil Tuggle

    Joined:
    Jun 29, 2015
    Messages:
    145
    Likes Received:
    53
    Location:
    Sumter SC USA
    Oh my goodness, no! I can never take credit - just read that somewhere, and followed the advice myself on my own tablet (I have a Galaxy Tab Pro 8.4 that seems to work great).

    I hope you find all the answers needed.
     
  10. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    Well, you were the one kind enough to relay the information, so, again: cheers for that! (I just finished another successful P3P flight-recording, without any of the problems I had earlier). :)
     
  11. mikatsan

    Joined:
    Aug 8, 2015
    Messages:
    13
    Likes Received:
    0
    When i try to disable Google Play Services, it actually asks for unistalling the current version and brings it back to factory default. Is this correct?

    *Lenovo S8-50
     
  12. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    Yes, that is correct (however illogical that seems to me...).

    I did this:
    Settings > Applications > Application Manager > ALL (scroll right if needed to see this option) > Google Play Services > Disable.
    A popup-window tells you something like: do you want to delete all info and turn off app? I chose to do that.
    Then another popup-window appears telling you that: the applications will be replaced by the standard version. It seems kind of weird to me, because I initially clicked on the "turn off" button, not the 'delete updates' . I chose to do that, anyway.

    I then got the message that it could not do this, because of some security settings. You click on an obvious button when you get that message window, to get to the security-settings area. T.b.h., I'm not exactly sure what I did there, but I did make a change there, that made sense, after taking a good look. (Sorry I cannot be more specific... I have gone through quite a bit of testing and making changes the last couple of days, to get it to work right, and unfortunately, I do not remember everything I did anymore...).

    What might also do the trick, is following these (detailed) instructions, to limit the number of background processes (to 1, I suppose? maybe none?): http://www.tomsguide.com/faq/id- ... android-device.html
    (B.t.w., if, under systems in settings, you do not see 'developer options' on your device, you have got to go to 'device info' and then tap some 8x on the 'build number'. That sounds kind of silly, but that is what you have to do to get the 'developer options' to appear).

    Good luck! Let me know if you've been able to work it out, and if so, maybe add to the instructions where they are a bit unclear.

    Cheers.
     
    mikatsan likes this.
  13. mikatsan

    Joined:
    Aug 8, 2015
    Messages:
    13
    Likes Received:
    0
    You are correct. I also did this administration "tricks" and finally i disabled it. Couldnt try it cause i have wind here but hope to try it soon.

    I also re enabled and actually updated the Google Play Services.. .

    Hope they provide with an update fix of this thing.

    Thank you for your answear!
     
  14. Mordor

    Joined:
    Jul 27, 2015
    Messages:
    639
    Likes Received:
    114
    I DO this: Rool back Google Services to factry mode.
    On Google Play, disable all updates (i do that even before buy DJI).

    On the phone/tablet before conect to RC, open google maps, charge your zone. Then turn off wi-fi, GSM and go Flight Mode.

    Than conect it to the RC. Also, be shure have the minimum apps running on the background...

    That normally works for my Phone and Tablet.
     
    mikatsan likes this.
  15. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    Hmmm... yesterday, I had the dji GO app crash on me once in mid-flight.. I'm not sure why. I landed the P3P, and turned off the tablet completely. Re-started it, and the app, and flew without a problem. Also today, I've made several flights without any trouble with the app.
     
  16. Mordor

    Joined:
    Jul 27, 2015
    Messages:
    639
    Likes Received:
    114
    Sometimes happens....
     
  17. mikatsan

    Joined:
    Aug 8, 2015
    Messages:
    13
    Likes Received:
    0
  18. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Suggestion always fly on airplane mode after you cache your map. Keeps other apps from interfering which may cause a crash
     
  19. LaChassagne

    Joined:
    Sep 12, 2015
    Messages:
    18
    Likes Received:
    1
    @Mordor - I'd like to know why. Plus, it shouldn't happen, though. If this happens when the P3P is completely out of sight and I've got only 5 minutes flight time left... Restarting the tablet and app takes a couple of minutes. I'd rather not rely on the return to home-button (although it does work. When I tested this once, the drone returned nicely home. Well, about 4-5 meters next to the home-point).

    @bobmyers - The airplane mode in always on, on my tablet. I actually never cache my map before flying. I do not have WiFi access at most places where I fly.
     
  20. Mordor

    Joined:
    Jul 27, 2015
    Messages:
    639
    Likes Received:
    114
    Its a "tricky" question....this morning i made use of a full battery, net, gps, everything ON and no issues at all.
    Even using 33 channels hack!

    Normally i charge the google maps and then turn ON Flight Mode before connect the cable. This time i just plug and use it......worked go figure...:rolleyes:o_O

    Just in case, i configure my RTH to always 66 meters!