Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

4k DJI GO disconnecting beyond 20-30 meters distance

Discussion in 'Phantom 3 Help' started by Per Edward, Oct 9, 2016.

  1. Per Edward

    Joined:
    Oct 8, 2016
    Messages:
    3
    Likes Received:
    0
    Im gonna start of by saying im new to this forum so im sorry if i put this thread in the wrong place..

    to the problem.

    i have just aquired a phantom 3 4k. and it works just fine. a problem i do have though is that when i try to calibrate it (gps) i get a message that it is in atti mode. and then the gps turns green still. when i start flying and go beyond 20-30 meters the app disconnects and i loose picture.. this is really annoying. everything else works fine.
    using an iphone 6s plus with ios 10
     
  2. Ken Nash

    Joined:
    Feb 8, 2016
    Messages:
    67
    Likes Received:
    24
    Location:
    High Wycombe, Buckinghamshire, England
    Try this...
    1. Delete go app an re-install it.
    2. Turn on remote controller.
    3. Turn on Phantom.
    4. Start DJI Go App.
    5. Let Phantom Warm up till Safe To Fly.
    6. Link the R/C with the Phantom.
    7. Re-callibrate Phantom.
    Try that and let us know how it goes.
     
  3. Per Edward

    Joined:
    Oct 8, 2016
    Messages:
    3
    Likes Received:
    0
    I will try it right away.. one question though since this seems to be a known issue with the dji go app.. is this also the case with other third party apps? cant find anything about that for example lichy or what its called
     
  4. Ken Nash

    Joined:
    Feb 8, 2016
    Messages:
    67
    Likes Received:
    24
    Location:
    High Wycombe, Buckinghamshire, England
    To be honest with I'm not sure myself but I think if you resolve this problem it won't be a problem with Litchi. What I do is when ever there is an App update I always delete the oldest App and install the new App so I know it's fresh and brand knew rather than over writing the old one. Anyway I hope it goes OK.
     
  5. Per Edward

    Joined:
    Oct 8, 2016
    Messages:
    3
    Likes Received:
    0
    tried another run yesterday. and even though it felt a little bitt better it didn't feel good. to much disconncting etc... will try different place to se if the area is the problem with interference etc... does anybody know if this problem is also in the lichi app?