Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI Go App showing as disconnected

Discussion in 'Pro/Adv Discussion' started by deano, Oct 6, 2015.

  1. deano

    Joined:
    Oct 6, 2015
    Messages:
    6
    Likes Received:
    0
    Hi

    My P3 advanced has been working perfectly until yesterday. I have around 80 flights so far.
    The app now just shows this message: "Disconnected"

    [​IMG]
    • Latest firmware
    • iOS9.0.2 on both ipad and iphone
    • Latest version of the DJI go app
    • Iphone 6 and ipad as well as android tablet
    • Different cables all apple originals
    • Fully charged battery
    • Tried rebinding the remote
    • tried everything in this thread: Advanced - Dji app -- USB disconnected | DJI Phantom Forum
    • Tried different IOS apps (FPV camera)
    • No crashes or damage to drone or remote
    Any suggestions?

    i can rotate the camera with the remote
     

    Attached Files:

  2. brianb87

    Joined:
    Aug 21, 2015
    Messages:
    788
    Likes Received:
    148
    Maybe try uninstalling and re installing app and FW. Seems like you have explored quite a few option. Have you tried a different battery, which was mentioned on the other thread.
     
    #2 brianb87, Oct 6, 2015
    Last edited: Oct 6, 2015
  3. vietnam phantom 3 ADV

    Joined:
    Aug 3, 2015
    Messages:
    12
    Likes Received:
    1
    I have same issue today, so I turn off and on DJ app, RC, I pad mini, P3, several time randomly , and patiently waiting each time, some how is get connect .
    That what i did, and don't ask me why cause I don't know It still work tomorrow, wait and see
     
  4. deano

    Joined:
    Oct 6, 2015
    Messages:
    6
    Likes Received:
    0
    latest version of dji go
     
  5. deano

    Joined:
    Oct 6, 2015
    Messages:
    6
    Likes Received:
    0
    I have just tried reloading the firmware through using a USB drive in the remote. The remote did not create a txt file nor acknowledge there was a firmware USB plugged in. The front LED just stayed red (as the phantom was off)
     
  6. deepeshdotcom

    Joined:
    Aug 20, 2014
    Messages:
    43
    Likes Received:
    8
    Location:
    Sydney, Australia
    I do face the same problem now and then. I am using Nexus II. I just turn it off for 10-15mins, take the battery out and try it again. Normally it works.
    Do you connect your tablet and fire up the app before you turn your drone on? Turn your remote on, Turn your drone on, and then connect your USB cable. hope it works.
     
  7. deano

    Joined:
    Oct 6, 2015
    Messages:
    6
    Likes Received:
    0
    I always turn the remote on first. I have tried leaving the tablet/phone unplugged until after both are turned on and also having it plugged in before.
    it feels like the USB point has stopped working...
     
  8. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Did you try to completely uninstall the DJI Go App before you upgraded to the version that was released last night.
     
  9. deano

    Joined:
    Oct 6, 2015
    Messages:
    6
    Likes Received:
    0
    No I just updated on the app store.

    It also showed the exact same error before last nights update.
    I thought the update might fix it but no.

    I also flew it a few times a week ago with the 1.4 firmware and the djigo app.

    cheers
     
  10. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Try to completely uninstall the app and go into the file in the device and make sure all the files for that app are deleted including the config files, then reinstall the New Go App-- worth a try :)
     
  11. deano

    Joined:
    Oct 6, 2015
    Messages:
    6
    Likes Received:
    0
    I have just tried a completely different device with a fresh install of DJI go
    Same issue. Just shows disconnected
     
  12. RangerOne

    Joined:
    Aug 16, 2015
    Messages:
    24
    Likes Received:
    6
    Location:
    Orange County, California
  13. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,729
    Likes Received:
    3,448
    One thing that can make it look like your camera is dead is that the Phantom doesn't like something about your SD card.
    Try another card and see if that makes a difference.
     
    P4King and xgaul like this.
  14. Jace

    Joined:
    Nov 22, 2016
    Messages:
    3
    Likes Received:
    0
    I know this thread is old but I'm having a similar problem on my P4. Was this problem ever resolved?
     
  15. Grammaton Claeric

    Joined:
    Jun 11, 2016
    Messages:
    385
    Likes Received:
    91
  16. RangerOne

    Joined:
    Aug 16, 2015
    Messages:
    24
    Likes Received:
    6
    Location:
    Orange County, California
    It eventually just stopped happening, and it's been extremely stable ever since. I don't recall exactly, but between continued DJI Go and firmware updates, it all worked itself out.

    Make sure you have the latest firmware applied to both the controller and the Phantom, and that you're running the latest version of the DJI Go app. I don't recommend downgrading to an earlier version of the app, as it may introduce compatibility issues with the newer firmware in the aircraft/controller. Another thing you could try is another piloting app like Litchi. If the disconnect still happens, it's likely a hardware issue. If it doesn't, you could try uninstalling and reinstalling DJI Go.