Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI Go and firmware depencency

Discussion in 'Pro/Adv Discussion' started by Ataribravo, Mar 30, 2016.

  1. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    To be sure I have it right (or wrong), there is seperate FW for the P3P, the batteries and the controller, plus versions of the DJI Go app. If I upgrade to the latest version of the Go app will it work with all versions of controller, battery and P3P FW? IOW, is there any piece of the system that, once upgrade, will require other parts of the system to be upgraded to work?
    Another strange thing: I started up the Go app and it stated that, "Download of the upgrade package P3 Standard 1.4.60 version was successful, please turn on your P3 Standard and connect the mobile device to its Wi-Fi." I don't recall downloading anything and I do not have a P3S, I have a P3P. Do I proceed with the install? If not, how to I get around (or delete) this? I cannot get past this popup message to install. If I were to delete the app and reinstall it (presumably to the latest version) would it work with my current (outdated) FW or would it require updating everything? Thanks!!
     
    #1 Ataribravo, Mar 30, 2016
    Last edited: Mar 30, 2016
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,842
    Likes Received:
    5,549
    Location:
    US
    After installing firmware 1.3.2, you can jump right to the latest version (or the desired version). DJI has been releasing "all-in-one" firmware updates -- meaning they can be installed on the batteries & Phantom. The RC can only be updated from the DJI GO app.

    If needed, you can find detailed firmware installation instruction here.
     
  3. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    I just accidentally hit Report instead of Reply on someone's response. My appologies :-( They were asking if I had downloaded the correct version of the FW from the DJI site (if I remember correctly). I have not downloaded any updates at this time. My P3P, controller and batteries all the the FW that they came with. The P3P is at 1.4.3. I don't know why the app thinks I have a P3S.
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,842
    Likes Received:
    5,549
    Location:
    US
    Try reinstalling DJI GO.
     
  5. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    That's was I figured would be the best action to take. Since the version of the Go app I install will most likely be newer than the one I delete, is there any chance of the new version not working with my olde FW? I do not know what the depencencies are with app versions vs. FW versions. Thanks!
     
  6. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,842
    Likes Received:
    5,549
    Location:
    US
    It should work with firmware 1.4.
     
    Ataribravo likes this.
  7. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    Ok, uninstalled old, installed new. I select P3P from the Phantom page dropdown. No more popup requesting install of P3S FW, but it will not connect (e.g. nothing happens when I hit the equipment icon). P3P, controller and phone are all fully charged. Phone is an HTC One (M8) running lollipop. Bird is on, controller is on and phone is connected. Help??
     
  8. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,842
    Likes Received:
    5,549
    Location:
    US
    And, how about if you reinstall the prior version?
     
  9. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    I would assume that, since I uninstalled it, I no longer have access to reinstall it. Actually, I don't know how to see what version I have currently installed.
     
  10. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    Interesting, I now have to log in just to see my Flight Records. Didn't have to do that before...
     
  11. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    Looks like I'm not the only one... A guy with the previous model to my phone (HTC One (M7)) is having the same issue, but so are Apple users and more. Why DJI... why?? Any suggestions?
     

    Attached Files:

  12. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    Found a site where you can get DJI Go versions back to 2.4.3, but which version is recommended for best functionality and stability? Note that the current version (and one I just installed is 2.7.1).
     
  13. MarkEt

    Joined:
    Jan 18, 2016
    Messages:
    44
    Likes Received:
    26
    Latest is best. Stop beating that dead horse !


    Sent from my iPhone using PhantomPilots mobile app
     
  14. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
    Unfortunately the dead horse seems to be the latest (2.7.1) as it is the one that doesn't work. And it's far from just me per the DJI Go site comments. I am all ears for a solution though. :D Please!
     
  15. BDOG

    Joined:
    Mar 22, 2016
    Messages:
    314
    Likes Received:
    108
    Location:
    San Jose Ca and Lake Tahoe NV

    Can you link the site?
     
  16. Ataribravo

    Joined:
    Oct 3, 2015
    Messages:
    42
    Likes Received:
    0
  17. chapy23

    Joined:
    Mar 21, 2016
    Messages:
    173
    Likes Received:
    21
    Beside all those problem you have, i really try to understand why version 2.5.x was 135mb and now 2.7.x are 91mb ?
     
  18. Trackman1

    Joined:
    Jan 1, 2016
    Messages:
    838
    Likes Received:
    211
    Location:
    Ontario, Canada
    I think it has to do with compressed size and installed size.