Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJi 550 failsafe failure!!

Discussion in 'Other DJI Multi-Rotors' started by PetePerrim, Mar 31, 2014.

  1. PetePerrim

    Joined:
    Jan 18, 2014
    Messages:
    138
    Likes Received:
    16
    Location:
    Christchurch, New Zealand
    I have had a 550 for the last few weeks and am running Naza V2 on it. Everything works well, it is nice and stable and behaves itself well except for when I try out Fail Safe. It has only worked once when testing. Every other time it climbs up the 20 metres and then tries searching for its home-point. At that stage it usually starts toilet bowling in ever increasing circles until it is clearly out of control. At this point I over-ride the failsafe and land it with either ATTI or GPS modes. I'd love to get this cleared up before I actually need failsafe, you know what I mean?

    I never take off until after I have received 2 sets of green flashes from the LED and because I have iOSD I can also see that it has connected to at least 7 satellites before take-off so Im 99.9% positive it has marked a home spot but it seems to forget where that is. Can anyone assist with what I might be doing incorrectly?

    Many thanks
    Pete
     
  2. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    That's a weird one Pete, I don't know that I've ever seen a report of TBE happening only when RTH is in process.

    What Tx/Rx are you using, and was it the same one as when you had the first successful RTH test? Also, can we assume you do get the fast flashing yellow from the LED when you trigger RTH?
     
  3. PetePerrim

    Joined:
    Jan 18, 2014
    Messages:
    138
    Likes Received:
    16
    Location:
    Christchurch, New Zealand

    The radio gear is a JR XG8. When its plugged into the Naza assistant it is definitely activating the failsafe and yes, I do get the rapid flashing yellow light indicating it is in failsafe. I have calibrated the IMU and every few flights I'll make sure I calibrate the compass. This morning I was playing around with the PC Ground Station (which doesn't work in my location due to proximity of Christchurch Intl airport 7.5 kilometres down the road) and then thought I'd test failsafe again so I calibrated compass and sent her up into the sky. Same result as usual. The one time it did work correctly was on the same radio gear, same location, same everything except that time it landed itself properly but I have not been able to replicate that since.
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Yeah it sounds like you're doing everything right, I'm stumped. The only other thing I could to think to test (though I doubt it'll make any difference) is to see if it does the same when you trigger RTH by the flight mode switch as opposed to shutting off the controller...I know it shouldn't make a difference based on how your Rx triggers it, but other than that I have no clue :(
     
  5. ladykate

    Joined:
    Jan 7, 2014
    Messages:
    994
    Likes Received:
    7
    Location:
    Bellevue, NE
    Does your radio have a separate failsafe? I ran into a failsafe problem with my Futaba that was due to the radio/rx having their own mind what a failsafe was. NAZA kept getting left out.
     
  6. tak004

    Joined:
    Mar 8, 2014
    Messages:
    20
    Likes Received:
    0
    Location:
    Sande, Norway
    Hi Pete,
    had the same issue with a Phantom I had, but no clue of the reason......
    You had a post regarding retractable landing gears, please answer my reply/Q. to that one ;)