Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Disconnected when turning on tx and app

Discussion in 'Pro/Adv Discussion' started by 30secs, Jul 2, 2015.

  1. 30secs

    Joined:
    Jun 12, 2015
    Messages:
    889
    Likes Received:
    113
    Happens to me only at the beach ironically. Turn in the TX then the app and it says disconnected. Retreat app and tx still doesn't help. Only one cable (Dji fc40 cable) out of 8 works. I don't get it.

    BTW can someone post the Dji USB that came with the p3? I didn't get one
     
  2. omarkatwe

    Joined:
    Oct 28, 2014
    Messages:
    149
    Likes Received:
    40
    Indidnt get one 2 and i dont think the error cus of the cable,
    Cus the old app was working good
     
  3. DJITomi

    Joined:
    Jul 6, 2015
    Messages:
    4
    Likes Received:
    0
    Went to five locations today; 3 by the river or lake, 2 on the mainland. Disconnected on every three locations on waterfront, but worked on two other locations perfectly.
     
  4. 30secs

    Joined:
    Jun 12, 2015
    Messages:
    889
    Likes Received:
    113
    Maybe the app prefers mountains over bodies of water...
     
  5. DJITomi

    Joined:
    Jul 6, 2015
    Messages:
    4
    Likes Received:
    0
    Statistically that'd be evident but in my case the problem was on the phone after all (surprise). App from DJI site, airplane mode on and PTP mode to USB connection fixed everything. Not sure which one of those in particular. Seems that the Oneplus One simply has too much to do when it's woken up in new location and therefore ADB starts to drop connection.
     
  6. 30secs

    Joined:
    Jun 12, 2015
    Messages:
    889
    Likes Received:
    113
    I'm using oneplus. Do you think our issue is device related? If so how did you set or check p2p mode?
     
  7. DJITomi

    Joined:
    Jul 6, 2015
    Messages:
    4
    Likes Received:
    0
    In english UI it'd be something like

    Settings -> Storage -> Three "dots" from up right -> USB connection -> PTP checkbox.

    I'm still not absolutely 100% sure that the problem is device related, but modifications to only Oneplus setup fixed the problems in app connectivity. I remember from my profession that "pure" Androids (Cyanogenmod, Nexus devices etc) seem to require the PTP mode on more often than others to achieve stable ADB, i.e. USB debug mode.
     
  8. DJITomi

    Joined:
    Jul 6, 2015
    Messages:
    4
    Likes Received:
    0
    Oh yes, some reasoning to the theory regarding PTP / airplane mode:

    Those two successful "mainland" tries I told about, had also second common denominator: They were "known" locations to phone, in a sense that the phone had plenty of time to locate itself, report the location to Google, update Facebook, emails, etc. you name it. Unsuccessful tries were those when phone was connected to TX "cold" (without waking it up first) and it seems that the constant ADB just couldn't keep up, at least without having PTP on.