Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. lobozx

    Joined:
    Aug 3, 2016
    Messages:
    3
    Likes Received:
    0
    Hello my fellow Phantom pilots!! I am probably not the only pilot suffering this "disconnect" nightmare at this current moment. I have the Phantom 4 and when I received it I followed the usual procedure of activating, calibrating and all the good stuff. I had a successful flight and flew 6 times already(pretty impressive machine).

    I already have upgraded to the latest firmware and it still didnt work. I then downgraded but it still shows as disconnect. I can arm the rotors and move camera but cannot see the camera.

    Dam!! I just got to Peru and wanted to film all of the Andes and this **** happens! I talked to customer support but no luck. all they say is to try a diffrent devce. FML PLs HELP?
     
  2. Michaelangelo

    Joined:
    Jul 7, 2015
    Messages:
    66
    Likes Received:
    18
    Sorry you are having this problem. Have you tried to delete the DJI GO app and then do a reinstall of it? That may work. It's worked for me in the past.
     
  3. herkam

    Joined:
    Jun 1, 2014
    Messages:
    25
    Likes Received:
    8
    Try a new usb cable, got problems with disconnect due to that.
    /Hakan
     
  4. lobozx

    Joined:
    Aug 3, 2016
    Messages:
    3
    Likes Received:
    0

    yes i have used several different cables but no luck.
     
  5. lobozx

    Joined:
    Aug 3, 2016
    Messages:
    3
    Likes Received:
    0

    I have reinstalled and installed several times and including reformatted my phone to original state. No luck.
     
  6. jwt873

    Joined:
    Apr 4, 2016
    Messages:
    311
    Likes Received:
    109
    Location:
    Woodlands, MB Canada
    I take it, that it's only the video that's 'Disconnected'. In this case, simply removing and replacing the MicroSD card sometimes works.

    I had that problem just last week. I went through resetting, rebooting and pulling my hair out. As soon as I popped out the MicroSD card, the video disconnected error went away and I had live video on my screen again.
     
    #6 jwt873, Aug 3, 2016
    Last edited: Aug 3, 2016