Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Desperately Avoiding Updates

Discussion in 'Phantom 2 Vision + Discussion' started by Bateman233, Aug 1, 2014.

  1. Bateman233

    Joined:
    Apr 29, 2014
    Messages:
    91
    Likes Received:
    3
    Anyone else refusing to do any updates on their Phantom Plus? I have not done a single update since I received mine several months ago and have well over 80 flights without a single incident. Don't want to mess with something that isn't broken!

    I like to keep my iPhone cleared of notifications but it's been impossible since DJI keeps wanting me to update the iPhone app. Afraid I am going to accidentally update it when updating other apps.
     
  2. z10m

    Joined:
    Jul 18, 2014
    Messages:
    140
    Likes Received:
    1
    Location:
    Tunbridge Wells, England
    can you not use newest iphone app with old phantom firmware.? i think some people here do that.
     
  3. DCGOO

    Joined:
    Jun 4, 2014
    Messages:
    109
    Likes Received:
    0
    Location:
    Indianapolis
    The new version of the app *says* the latest firmware is required. I never tried it myself. I have always upgrade the app and the firmware at the same time.
     
  4. skyhighdiver

    Joined:
    Dec 19, 2013
    Messages:
    1,007
    Likes Received:
    211
    Location:
    South Dakota
    Well I can say that I finally came off of 1.08 and did a full update to 3.06 have made 8 full battery flights now and all is well :D
    Tested RTH, low battery come home and all video funtions , as well as atti and gps seems there is nothing to worry about.
     
  5. BlackTracer

    Joined:
    Mar 29, 2014
    Messages:
    980
    Likes Received:
    22
    Location:
    Winter Park, FL USA

    I did the EXACT SAME THING. I said I would never come off 1.08, but did and am liking 3.06 and the new vision app.
     
  6. RedBaron

    Joined:
    Jul 5, 2014
    Messages:
    132
    Likes Received:
    0
    I do not like 3.0.6 at all. Almost lost the plus on first flight and almost crashed on second flight. I do not like the new low battery and critical upgrades. Is there a way to revert back to 3.0.4 which was very stable for me.

    RedBaron
     
  7. Werz

    Joined:
    Jun 21, 2014
    Messages:
    143
    Likes Received:
    1
    Crap! I allowed my phone to update the DJI Vision software to 1.0.52 a couple of days ago, but I have not flown my Phantom or hooked it up the Phantom 2 Assistant software since then.

    Does that mean I cannot use the DJI Vision 1.0.52 until I flash the firmware on the Phantom to 3.0.6?
     
  8. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    Rolling back the Vision+ app is easy. Rolling back the Phantom firmware appears to only be possible if you do major downgrades (i.e. 3.x > 2.x, or 3.x > 1.x) You can download different versions of the phone app, but I've never seen the Phantom's minor firmware revision available (ie 3.0, 3.02, 3.04, 3.06).
     
  9. Sasquatch

    Joined:
    Jun 7, 2014
    Messages:
    242
    Likes Received:
    0
    Location:
    Ontario, Canada
    I'm a relatively new phantom owner myself and completely new to any kind of RC unit. I've been reading the topics and opinions from the masses and I've been reluctant to upgrade my bird too. It came with 3.0 and I was mostly satisfied with its performance for awhile. Changed to NAZA mode and have been having some issues but that is another story and probably not related.

    However and upon further thoughts, I believe it's in our best interest to upgrade to the newer firmware and software when it comes up. Saying this though, it's good to wait a bit as well to get feedback from the early adopters. In regards to the newest firmware and app, it seems that the *majority* are happy with the upgrades.

    It often comes down to little particular parameters that certain phantom owners don't want changed at any cost

    Just my two cents.
     
  10. Imhenry

    Joined:
    Apr 17, 2014
    Messages:
    13
    Likes Received:
    0
    i am still using 1.08 with ios 1.041 app, works great. i just recently got rid of fpv issue, so never wanted to change anything after that, and besides that, i hate that "restricted area" thing!
     
  11. RedBaron

    Joined:
    Jul 5, 2014
    Messages:
    132
    Likes Received:
    0
    To revert back to 3.0.4 from 3.0.6, run the 3.0 assistant software. Go to the upgrade tab and you can upgrade from 3.0.6 to 3.0.4. You can do the same for the other items you want to get back.