Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Defective gimbal? Tilt twitch jello issues

Discussion in 'Phantom 2 Vision + Discussion' started by ocphantom, May 12, 2014.

  1. ocphantom

    Joined:
    Apr 25, 2014
    Messages:
    98
    Likes Received:
    0
    Here's the video showing the, what I believe is, defective gimbal of my Phantom 2 Vision Plus.
    https://www.dropbox.com/s/lhuela7fdznzu56/DJI00030.MP4

    The jello affect is there pretty much from start to finish. You'll see the
    gimbal twitch from right to center around the 0:22 mark. Also, notice the slant/tilt in the camera.

    When I do a power cycle of the Phantom, the camera goes back to being level. Its level when I power on the Phantom before CSC. After CSC and when its airborne the gimbal twitches and the cameras tilts a few
    degrees, not to mention the jello affect becomes apparent. Also when its on the ground I sometimes get the gimbal error message on my fpv on my iPhone.

    I have all the latest firmware, 3.02, 1.0.1.27 etc. btw. Filmed that at 1080p30fps.



    Is the issue?
    1) firmware
    2) hardware (defective gimbal)

    Any confirmed fixes?

    TIA!
     

    Attached Files:

  2. gd427driver

    Joined:
    Apr 13, 2014
    Messages:
    10
    Likes Received:
    0
    Just posted a message and video with the same problem. My twitchy gimbal it worse than the jello but both are there. Hope there is an easy solution as spares appear to be non existent and Ive only had the P2V+ a week. :(
     
  3. beachvision

    Joined:
    Dec 29, 2013
    Messages:
    52
    Likes Received:
    0
    Hey guys...
    They gotta go back....well that is unless DJI comes up with a fix for it. I had bad jello and gimble twitch to the left mostly. DJI told me to send it in for diagnosis(approx one week diag time)....UMMMMMMMMMMMM.NOOOOOOOO

    Return for refund,
    Bought another through Daves ...this one is perfect. Very happy..

    Send em back guys!
     
  4. ocphantom

    Joined:
    Apr 25, 2014
    Messages:
    98
    Likes Received:
    0
    Fixed it. Hardware issue. Changed gimbal and video has no more hello or twitch. I believe jello was coming from the vibration of the gimbal. I did hear a constant humming noise from the gimbal