Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Current firmware etc version ?

Discussion in 'Pro/Adv Discussion' started by Volkhard, Dec 3, 2015.

  1. Volkhard

    Joined:
    Jun 18, 2015
    Messages:
    125
    Likes Received:
    83
    Location:
    USA, Florida
    Hi guys
    For the last 2 month+ life got in the way and my Phantom 3P had a long break. Preparing for some flying and shots the coming Saturday I was wondering whether I am up to date. I visited DJI wiki: they are stating 1.1.8 as the current release! It seems an update is neccessary otherwise the wiki is worthless.

    Can someone update me on all the current versions for:
    --- Firmware
    --- Batteries
    --- Remote
    --- DJI GO
    --- Litchi
    It is very much appreciated.
     
  2. olof Ekbergh

    Joined:
    Sep 30, 2015
    Messages:
    252
    Likes Received:
    137
    Location:
    Mt Washington Valley
    This is what I run. I think battery update is included, someone here may be able to confirm. 1.3.2 was the last time I noticed the batteries were updated, but I have not checked the log or had a message to update any batteries the were not in when updating to 1.5.30.

    app 2.4.2
    fw ac 1.5.30
    fw rc 1.5.70

    iOS 9.1 on a iPad mini 2
    I don't use Lichi or an Android Pad.
     
    bobmyers likes this.
  3. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    olof has it nailed-- you may need some of the previous versions, if you cant go from 1.1.8-- I still have copies of the other upgrades-- speak up if you need them.
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,068
    Likes Received:
    5,614
    Location:
    US
    It's best to check the DJI downloads page for the current firmware version. The DJI GO app will also alert you if there is a new version to install on the Phantom/RC/batteries.
     
  5. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,068
    Likes Received:
    5,614
    Location:
    US
    It would be best to install 1.3.2 and then 1.5. The 1.4 release can be skipped.
     
    bobmyers likes this.
  6. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    I hope there is not another-- olof posted the current version that we are aware of-- unless they changed in the last couple of days-- is there another more recent?:)
     
  7. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,068
    Likes Received:
    5,614
    Location:
    US
    Right -- but, the OP is trying to check the version on the wiki... :)
     
  8. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    you have to be more detailed with us old folks-- we are slow thinkers...:D:D
     
  9. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,068
    Likes Received:
    5,614
    Location:
    US
    Hah, don't worry... I'm usually more patient than most people :D
     
    bobmyers likes this.
  10. Volkhard

    Joined:
    Jun 18, 2015
    Messages:
    125
    Likes Received:
    83
    Location:
    USA, Florida
    Thanks guys. I have 1.3.2 and will go directly to 1.5 looked up Litchi qnd DJI go in the google play store and was able to update both as well. I will download the firmware tonight and update the phantom in the morning and shouod be up to date.
     
  11. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Welcome back to the real world:D:D
     
  12. johnbigboote

    Joined:
    Nov 5, 2015
    Messages:
    4
    Likes Received:
    0
    Does the r/c firmware always have to match the latest drone firmware? I still have 1.19 on my r/c and it works fine for me.