Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

crazy video playback problem

Discussion in 'Phantom 2 Vision + Discussion' started by bighi, Mar 12, 2015.

  1. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    I've got the craziest video playback problem. On my phantom 2 vision I've never experienced this. But has been happening with my plus v3 ever since the first flight a week ago. It records video fine. Then I go to play it back (Samsung S3 mini) and says "video can't be played." I swapped SD cards with my vision and it worked while filming a video on my kitchen table. I take it outside the next day and recorded while flying. I go to play it back and nothing. I take the SD card out, take it to the computer and it plays perfect. Ok, card back in the plus camera, reset camera, records and plays back on the Samsung. But I have a feeling it will happen again. Any opinions on this one?
     
  2. cahutch

    Joined:
    Jul 8, 2014
    Messages:
    558
    Likes Received:
    4
    Location:
    Sonoma County, CA
    Are you making sure to stop the recording before you power off the Phantom?
    If you forget (like I do sometimes) the video won't play. You have to put the card back in the Phantom and cycle power to close the file so it will play back.

    Are you trying to play back from within the vision app over the WiFi link? I wouldn't expect that to work due to the low bandwidth available on the wifi link.
    I can barely get it to download stills that way.
    It's best to remove the SD card and copy or play back video on the PC from the card.
     
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    +1 cahutch

    Check your card and see if its legit viewtopic.php?f=4&t=36312
    Also make sure you are not recording in 1080i@60fps (not all phones can play this).
     
  4. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    I'm starting to suspect that the issue has something to do with the SD card. But maybe not so much the card but the contacts in the camera contacting the card instead. Only this would explain the camera doing what it's supposed to do after an SD card swap and then next day not working again after some movement by the phantom.
     
  5. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    I've the same problem with my note 4 since I've updated camera firmware of vision plus to version 1.3.0g (latest available). With the previous version I haven't this problem...it's the time that we move and wrote on official dji forum? I've tried to explain the problem to dji support but even with LOT of mails to understand what I was asking them (and believe me was very simple) they told me that this problem is only mine and they tell me also that the they can't provide me the previous firmware version 1.2.9g to downgrade. Fool.
     
  6. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    Mako, I'm using stock card came with my p2v plus. It can't be the card the root cause.

    Maybe the format method? I've formatted that with windows seven normal formatting utility.
     
  7. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    It's working sporadically for me right now. I have it sitting on a table. I turned it on two hours ago and filmed a one minute video. Playback on the Samsung worked. Tried a two minute video and it worked. Just now I tried an three minute video and playback started and then five seconds into playback comes the message on a white background again "can't play video." I'll go try again. After months and months of no issues with playback on my p2v on the same mobile device, with the same exact camera settings, I'm stumped as to why this is happening on my new p2v+.
     
  8. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    Which camera firmware version you have?
     
  9. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    Which firmware I have I need to check. Right now I just finished two videos. A ten second one and then a two minute one. Both played back on the android phone, both downloaded through the WiFi connection to the phantom with no playback issues. This is nuts! It works when it wants to.
     
  10. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    Just checked firmware. It's 1.3.0. Makes sense since it's barely two weeks old.
     
  11. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Use the phantom app to format the card. This will allocate the correct structure. It will still read under windows.

    Test the video playback via the PC and not the phone. There are number of phone apps that have different codecs that may not be compatible. Also, don't download the video via wifi from the Phantom. It takes too long and with the props not spinning, this can lead to the wifi module overheating and therefore failing. The wifi module has a poorly designed heat dissipating system and also poorly constructed using crappy white thermal paste. I'm not sure if the newer perforated wifi modules have addressed this issue.
     
  12. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    I'll try to format with dji app, never done in this way. And I use to download video through wifi when finished because I like to watch them istantly...I didn't notice overheating but I've not checked...thanks for the advice.
     
  13. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    Never had an overheating issue on my p2v after over 150 fights. I like to watch the videos instantly as well or delete as needed and format before the next flight. Anyway, if that WiFi module was overheating, it never showed any symptoms flight after flight.
     
  14. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    421
    Location:
    North York Moors
    The wifi module in P2V is in the camera, it's in the main body with V+.
    Overheating has been implicated in a rash of failures last year, and they redesigned in in V3 with airholes but it is still worth being aware of.
     
  15. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    I'll be honest, I'm starting to like my indestructible, non plus vision a heck of a lot more. On a RE700 range extender I am getting an easy 900 meter range with no further mods. Never a camera blackout which I've already gotten on the plus. Never worrying about burning a mosfet or breaking motor wires. If the camera craps out, which is unlikely, it's cheap. I can play back videos on my mobile device without a care. I can throw it in a backpack without worries of the gymbal getting damaged. No gymbal horror stories after firmware updates. I don't know but, other than the gymbal on my plus, I'm not too impressed. Anyway, here is what my camera is doing. Inside my apartment the videos are fine and play back. The moment I go outside in the cold the videos are no longer playable. I tell you, these plus cameras are finicky. Anyway, off to fly my phantom. The vision non plus this time. Good old honest quad.
     
  16. happydays

    Joined:
    Jul 5, 2013
    Messages:
    1,858
    Likes Received:
    663
    Location:
    Warrenpoint, Ireland
    But compared to the V+, the footage looks horrible with all the shaking and vibration?
     
  17. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    Shaky footage is better than footage that cannot be checked out in the field. Besides, YouTube can work wonders on somewhat shaky footage
    06.11.2014: http://youtu.be/EcWkETl91zQ
     
  18. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    Well if your problem is only how to check the footage install VLC player for android and problem solved.
     
  19. bighi

    Joined:
    Oct 15, 2014
    Messages:
    454
    Likes Received:
    150
    Location:
    Gibraltar/Austria/Italy
    Swapped camera, flew it in even colder late afternoon weather, no problem. Perfect playback, no need to doma multi device SD card dance. Playback, download to device, upload, all on location. Moral of the story? Just like DJI range extenders, no two DJI same parts work the same. I'm sending it in.
     
  20. StevenQX

    Joined:
    Mar 1, 2015
    Messages:
    786
    Likes Received:
    185
    Location:
    Italy
    Which firmware you've in the swapped camera?