Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Crazy twitchy gimbal

Discussion in 'Phantom 2 Vision + Help' started by shiftline, Nov 5, 2015.

  1. shiftline

    Joined:
    Oct 18, 2015
    Messages:
    32
    Likes Received:
    0
    I hair replaced the flex cable on a p2 v+ and the gimbals jerks around and twitches like crazy.


    I watched a YouTube video about making sure the flat spot on the horizon cable is facing down (with drone upside down)


    [​IMG]

    In the app it says to remove the gimbal guard
    [​IMG]


    What else would make the gimbal go crazy?
     
    #1 shiftline, Nov 5, 2015
    Last edited: Nov 5, 2015
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    Check the grub screw at the top of the gimbal arm. Its on the opposite side of the flex cable. Make sure its tight against the flat side of the shaft.

    Or one or more of the potentiometers are damaged. Check if there is scratches or dents in the pots. The scratches or dents will give it spiked values and hence the twitchy gimbal.
     
  3. hunch

    Joined:
    Oct 10, 2014
    Messages:
    1,500
    Likes Received:
    225
    You need a new Pitch sensor board.
    PM me if you want me to send you one. i have plenty
     
  4. shiftline

    Joined:
    Oct 18, 2015
    Messages:
    32
    Likes Received:
    0
    I checked Both pots. No nicks or dents
    [​IMG]
    [​IMG]

    Bottom yaw arm is screwed into the flat side
    [​IMG]
    And tight


    Camera was screwed into the rounded side of arm
    [​IMG]

    I made sure pot of the yaw arm had the flat spot level What else am I missing?


    It was doing the same thing before so I swapped the camera and motor/board from the one connected to the camera and mounted it to the old base/yaw arm. And it still does the same thing of twitching out

    What else am I missing? I guess I could try swapping the boards one at a time
     
    #4 shiftline, Nov 5, 2015
    Last edited: Nov 5, 2015
  5. shiftline

    Joined:
    Oct 18, 2015
    Messages:
    32
    Likes Received:
    0
    I swapped the driver for the motor attached to the camera.

    Now it stabilizes ish but the motors are making noise while doing so and the app thinks the gimbal is obstructed


    [​IMG]
     
  6. shiftline

    Joined:
    Oct 18, 2015
    Messages:
    32
    Likes Received:
    0
    The camera motor doesn't seem as smooth as it should be. Where can I find replacement motors?
     
  7. shiftline

    Joined:
    Oct 18, 2015
    Messages:
    32
    Likes Received:
    0
    Woo. I think I found a working combination!

    Does anyone use/have any of the gimbal guard type products
     
  8. shiftline

    Joined:
    Oct 18, 2015
    Messages:
    32
    Likes Received:
    0
    First real flight!
    Is shutter roll normal with a phantom 2 v+?
     
  9. Bkuhn

    Joined:
    Nov 14, 2015
    Messages:
    3
    Likes Received:
    0
    Hutch, I'm having the same issue. All shafts and pots seem ok and are tight, but gimbal dances. How do I get a pitch sensor from you? Maybe mine busted. Trying everything I can. Thanks.