Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Crazy question

Discussion in 'Phantom 2 Vision + Discussion' started by Geoelectro, Sep 6, 2015.

  1. Geoelectro

    Joined:
    Feb 16, 2014
    Messages:
    324
    Likes Received:
    40
    Location:
    Houston Tx.
    I have a P2V with 1.08 firmware. It's a backup craft to my P2V with 3.14 FW.
    I have a P2V+ friend who wants to buy my P2V. He asked me if there was a way to put the 1.08 from the P2V to his P2V+. I assume the firmware is in the main control board which I don't believe is compatible. I don't own a P2V+ so I'm not that Familiar with it.

    Anyone know?

    Geo
     
  2. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    The firmware is written for the particular model craft. Would not recommend trying to mix the software.
     
  3. BlackTracer

    Joined:
    Mar 29, 2014
    Messages:
    980
    Likes Received:
    22
    Location:
    Winter Park, FL USA
    I ran 1.08 on my P2V+ for at least 6 months when I first got it back in May of 2014. It flew like a champ. Never a problem. It came with 3.02 I believe when I got it.
     
  4. Geoelectro

    Joined:
    Feb 16, 2014
    Messages:
    324
    Likes Received:
    40
    Location:
    Houston Tx.
    That's what he's hoping for. Is the firmware in the NAZA module? If so couldn't it be changed out with one from a P2?

    Geo
     
  5. BlackTracer

    Joined:
    Mar 29, 2014
    Messages:
    980
    Likes Received:
    22
    Location:
    Winter Park, FL USA
    If you go to The DroneSlinger.. you can download and install assistant 1.08. It used to be that you could downgrade to FC firmware to 1.08 using that assistant. But I haven't tried in a long time. Also you may run into other fw incompatibilities with the fw that is loaded on other modules besides the FC. I don't know. Good luck.