Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Controller won't stop beeping.

Discussion in 'Pro/Adv Discussion' started by Colbycheese08, Jul 27, 2015.

  1. Colbycheese08

    Joined:
    Jun 15, 2015
    Messages:
    30
    Likes Received:
    0
    Hey thanks for checking on this for me. I have been in able to fly my bird for about 8 days now. Up till now it has been amazing! Around 175 hours logged.
    Anyway to the point after 8 days I turned it on with the propellers off to do a check on everything priory to a true flight. I tuned my controller on first and then the bird, my controller began to beep very loudly, with the red light flashing. I powered it down and turned it back on the same thing. It stopped once I initiated a take off (still with propellers off). Either way I ain't flying it until you guys give me an idea what I need to recalibrate or what ever else I may need to do.

    -----to who ever says go read your manual and then re read it! Screw you!! This is one reason this is here to ask questions!! Thanks for the help.
     
  2. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    I don't believe there would be an answer in the manual. What version firmware are you running? Did you get any errors in the app?. What was the Aircraft status on the app.
     
  3. phantom3menace

    Joined:
    Jul 10, 2015
    Messages:
    208
    Likes Received:
    92
    My Inspire controller did the same thing straight from unboxing. I calibrated the control sticks and that fixed the problem.

    I hope this helps.
     
  4. Phantom751874

    Joined:
    Mar 13, 2015
    Messages:
    995
    Likes Received:
    269
    Mine has started doing this as well. If I turn it on and start moving the sticks around the beeping stops. I didn't think to do an RC calibration do I guess I'll try that.
     
  5. Colbycheese08

    Joined:
    Jun 15, 2015
    Messages:
    30
    Likes Received:
    0
    Thanks everybody. I had tunnel vision and was freaking out, the status showed I needed to do a RC calibration. So u all was right. Thanks! That fixed it right up.

    I just hope the fear of flying settles down one day. I'm so scared or crashing it. But it one way that's a good thing it keeps you on your toes and helps not do nothing stupid.
     
  6. J Smith

    Joined:
    May 27, 2015
    Messages:
    33
    Likes Received:
    4
    My controller done the same thing, I realized just lightly tapping the left control stick immediately stopped it. So apparently I need a "RC" Calibration as well, although it only takes 1 second to turn off the beeping. But geez... was it a pain to figure out such a simple solution. It drove me crazy for about 10 flights before I figured it out.
     
  7. Colbycheese08

    Joined:
    Jun 15, 2015
    Messages:
    30
    Likes Received:
    0
    It's just everybody's fear that something internal will mess up and cause a crash. That's why every time before a flight I power on with no propellers and do a run through.
     
  8. mohan

    Joined:
    Jan 3, 2015
    Messages:
    527
    Likes Received:
    206
    Calibrate the RC controller and the beeping will stop. Otherwise move the sticks 2-3 seconds after RC controller has powered up
     
  9. wlkngmachine

    Joined:
    Jan 6, 2016
    Messages:
    22
    Likes Received:
    2
    I had the same problem, thanks for these answers!
     
  10. Thomas Cole

    Joined:
    Aug 11, 2015
    Messages:
    68
    Likes Received:
    17
    Good answers had same issue....I calibrate both camera, controller and aircraft (use my pool table...level lol) Gives me peace of mind....165 flights on my P3A.....no surprises.