Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Controller not connecting to PC software.

Discussion in 'Phantom 2 Help' started by Jourei, Sep 6, 2014.

  1. Jourei

    Joined:
    Sep 6, 2014
    Messages:
    24
    Likes Received:
    0
    So I'm having this major issue with DJI software not recognizing my Phantom 2's controller.

    I have no idea where to really start, other than that I've tried plugging to my motherboard's USB ports and reinstalled Windows' drivers, but neither of the Phantom nor RC System Assistants seem to get a hold of the device.

    Any advice on this matter?
     
  2. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Does the Phantom assistant recognize the Phantom when it's connected? If so that will eliminate some potential causes from the list.
     
  3. Jourei

    Joined:
    Sep 6, 2014
    Messages:
    24
    Likes Received:
    0
    I feared someone would pick that up... The thing is, my Phantom 2 itself is currently in repair in Germany due to a weird crash, so I don't have the unit here to try that out.

    Are there any tricks that could still be tried out until I get the phantom back?
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    You mentioned drivers, but did you install the DJI WIN driver?
     
  5. Jourei

    Joined:
    Sep 6, 2014
    Messages:
    24
    Likes Received:
    0
    I actually did not as I didn't know what that was. Then again, it does say drivers...

    Well, installed that and now everything is fine.

    I'll now go and shame myself for not properly researching the obvious options...
     
  6. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Glad it's working for you now, and don't feel bad at all....lots (and lots) of people miss that one at first ;)