Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Constant beeps after replacing main board

Discussion in 'FPV (First Person View)' started by Phantom808, Feb 22, 2015.

  1. Phantom808

    Joined:
    Feb 15, 2015
    Messages:
    3
    Likes Received:
    0
    Triple checked everything, constant beeps, crazy flashing LED's (fast red). Update doesn't help.

    Replaced my board after frying my FPV port. Now it has a constant steady beep on start up. Tried everything....

    Any info would help

    Thank you!!!
     
  2. CityZen

    Joined:
    Oct 22, 2014
    Messages:
    940
    Likes Received:
    36
    Location:
    NYC
    Verify you have +5.5V at the X3 connector (brown = gnd, red = power).
    Which Phantom do you have?
     
  3. J.James

    Joined:
    Apr 21, 2014
    Messages:
    1,882
    Likes Received:
    162
    Location:
    Upstate NY
    Also make sure the plug that controls the motors that goes in to the m1 m2 m3 m4 ports of the naza is in the right row of pins.
    and if you know all 4 plugs to all 4 escs are plugged in and pushed down all the way then start checking the soldering on the power wires from the main board to the escs is indeed soldered down really good.

    a few weeks ago when replacing a board I had one wire to one of the escs that even tho it looked like it was soldered down really good It was giving me the beep beep beep thing intill I soldered the joint again.

    and the m1 m2 m3 m4 plug is some thing that I useally end up plunging in wrong every freaking time any time i have replaced a board.