Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Compass error/Atti mode switch?

Discussion in 'Pro/Adv Discussion' started by smoke23, May 30, 2015.

  1. smoke23

    Joined:
    Apr 27, 2014
    Messages:
    46
    Likes Received:
    5
    Location:
    Hickory, NC
    So I just got home from flying yesterday and I had a weird experience. I did a IMU and gimbal calibration today. I went to my location, did the usual compass dance, put it in the air, stable, put it up about 80 feet and started flying and got a compass/atti mode error and I pulled it back real quick, it kept drifting as it said it went into ATTI mode, my heart sank for about 3 seconds because it just kept drifting and GPS finally kicked back in. Rest of the flight was ok. What would cause it to do that?
     
  2. damitjim

    Joined:
    Apr 15, 2015
    Messages:
    291
    Likes Received:
    149
    Location:
    NC
    Mine did the same thing yesterday, strange.
     
  3. keeny

    Joined:
    Apr 25, 2015
    Messages:
    50
    Likes Received:
    7
    Not sure what happened, but in atti mode it will drift its up to you to fly it .
     
    damitjim likes this.
  4. Badabing

    Joined:
    Mar 16, 2015
    Messages:
    27
    Likes Received:
    6
    Had a similar experience a few days ago (Loss of GPS to ATTI) . The wind took the quad sideways quite quickly. I was in an open area so the wind would do this (approx. 200ft up) in ATTITUDE mode as previously mentioned.

    I was caught off guard for a few seconds and realised what was happening and took control. Just conscious of this now are prepared to counter the effect of the wind. It's only happened once though.
     
  5. Coldfire

    Joined:
    Feb 8, 2015
    Messages:
    203
    Likes Received:
    90
    I've also have had this happen to me. I was about 1500 ft away from the TX. Thank goodness I've flow some quads before with gps assistance and was able to bring it home without issue.
     
  6. LostInSky

    Joined:
    May 10, 2015
    Messages:
    38
    Likes Received:
    3
    I have today a one really bad experience with my p3, it take 10 years of my life for sure. I was at open area (beach), and I felt a little bit of wind so I decide to land and quit with flight. In that moment my P3 start losing control, and when I look on my tab, I saw COMPAS ERROR. I was scared and I just try to go up (because he goes down and near houses). After 10 seconds finally he find GPS and I land with my P3 normally. What was wrong? Is problem with wind (but really not so strong)?