Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Compass calibration fails

Discussion in 'Phantom 1 Help' started by bdmsb, Jul 26, 2013.

  1. bdmsb

    Joined:
    Jul 25, 2013
    Messages:
    15
    Likes Received:
    0
    I have a new Phantom. I'm trying to get it ready for a first flight. I cannot get the Compass calibration to work. I flip the GPS/Atti switch 10 times quickly, but get no yellow light. I've tried several times.

    I may be running firmware 3.12, if that matters. I have been unable to get Assistant version 2.14 to run, so I ran version 2.12 instead, and it tells me the firmware is 3.12.
     
  2. FangsCPO

    Joined:
    Apr 7, 2013
    Messages:
    793
    Likes Received:
    3
    Location:
    Chula Vista, CA
    I have the same problem. It takes a while to make it go into calibration mode. Try 8 times vs 6 or 10. I have no idea but that has worked for me.

    Sent from my SCH-I535 using Tapatalk 2
     
  3. PhantomHubert

    Joined:
    Jul 27, 2013
    Messages:
    8
    Likes Received:
    0
    If i remember correctly you have to start and end in ATTI.
     
  4. martcerv

    Joined:
    May 27, 2013
    Messages:
    1,002
    Likes Received:
    2
    Since the last few updates you need to finish on atti, if you have position 3 set as something other then atti also make sure to only flick GPS and ATTI and finsih on atti after 6-8 flicks and it should work.
     
  5. bdmsb

    Joined:
    Jul 25, 2013
    Messages:
    15
    Likes Received:
    0
    I got it to work, but I think it may have to do with how fast I flipped the switch. The directions say "fast", and I was trying to go as fast as I could. But watching the video, he's diligent but not super fast. I slowed down and it worked.