Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

CMOS sensor error on camera appeared after firmware update. How to fix?

Discussion in 'Phantom 2 Vision Help' started by Zefnoly, Jan 3, 2016.

  1. Zefnoly

    Joined:
    Dec 28, 2015
    Messages:
    47
    Likes Received:
    4
    Location:
    Norway
    I tried to update the camera to fix a problem where i needed to rebind the drone whenever i was going to use it without frozen picture on the camfeed. Now the camera doesn't even work anymore.

    I updated just like in the manual. But the latest firmware update on the MicroSD card while it was clean. Then it was inserted into the camera. turned on the drone, camera started with yellow flashing as the update was going on. The camera went green as it was successful. Turned it off and put the SD card back into my computer. the firmware file was changed to have ".bak00" behind it like the manual told it would do if it had successful update.
    Then I put the card back into the drone and turned it on. After it got powered the camera had red/orange light slowly blinking. Manual says it is CMOS error and nothing works in the app. No camfeed, no telemetry, no battery indication, nothing. I tried to reboot the drone 3-4 times but all of them has same results. CMOS error. Cant find anything on google able to help me (not so far). the only threads i found was about vision+ but i got just vision.

    Please tell me how to get the camera working. I don't have any payment confirmations, got this as present so i cant return it anywhere. I can try to talk with some stores selling those nearby but it will probably lead to nothing as i dont even know where this drone was bought...