Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Choppy Video after updating to the newest firmware

Discussion in 'Phantom 3 Help' started by S.W. Phantom Pilot, May 2, 2016.

  1. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    Hi. I bought 2 new batteries so I decided to upgrade to the latest firmware. Now all my video is suddenly choppy. I use Litchi to fly but I never had this problem until I upgraded the firmware. Could I have done something wrong ? The upgrade said it was successful. Your help figuring this out is appreciated. I wasted the whole weekend at the beach filming unwatchable video
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,416
    Likes Received:
    568
    Location:
    Sydney Australia
    Choppy where? FPV or playing back on your device/PC??
     
  3. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,043
    Likes Received:
    5,608
    Location:
    US
    After installing new firmware, some of the Phantom settings are reset. Take a look through them and ensure they are all set to whatever you were using prior to installing the firmware.
     
  4. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    choppy on my PC after I load the sd card
     
  5. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    Never did it before.
     
  6. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    FPV is smooth. I'M flying with Litchi
     
  7. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    Litchi was reading at 30 per second now reads at 60 per second
     
  8. Mat Rix

    Joined:
    May 3, 2016
    Messages:
    5
    Likes Received:
    0
    i have exactly the same problem ... never something like this before ... after upgrade to latest firmware recorded video "choppy" ... video on iPad is ok ... but recorded on SD is damaged ... as you said "choppy"... it seems to be the problem with new firmware
     
  9. Great_Lakes

    Joined:
    Apr 22, 2016
    Messages:
    268
    Likes Received:
    68
    Location:
    South Eastern Michigan
    What version of firmware? I have recently updated to the latest; 1.8.08, or something like that and I have no issues with my video. I'm using an iphone 6 for FPV.
     
  10. Mat Rix

    Joined:
    May 3, 2016
    Messages:
    5
    Likes Received:
    0
    I have 1.8.80 ... latest one ...
     
  11. Mat Rix

    Joined:
    May 3, 2016
    Messages:
    5
    Likes Received:
    0
    Problem solved at least for me ... files are ok ... it was problem with player
     
  12. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    Mat Rix What video player were you using and how did you fix it.? It sounds like I erased 2 weekends of shooting video at the beach
     
  13. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    Mat Rix. I'm using Windows media player. What are you using and how did you fix it ? It sounds like I erased 2 weekends of shooting at the beach for no reason.
     
  14. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    It was working fine before I did the upgrade
     
  15. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    I upgraded to 1,8
     
  16. S.W. Phantom Pilot

    Joined:
    Apr 16, 2016
    Messages:
    25
    Likes Received:
    0
    problem solved. Installed another media player and now the video is smooth. Hope this helps someone.
     
  17. Mat Rix

    Joined:
    May 3, 2016
    Messages:
    5
    Likes Received:
    0
    Movies in 4k require good computer (hardware) and good player ... im using macbook pro with few different players ... i was surprised because player that worked fine ... suddenly starts chopping. .. after longer examination i've found out ... that some other software in background "colide" with my player ... as a good player i can recomend kodi ....